iBook dropping internet connection

in Genius Bar edited January 2014
I'm using a new(ish) iBook running Mac OS X 10.1.

I have a problem connecting to the Internet. It keeps dropping - connects OK, stays connected for a minute or so, then the connection breaks.

After 5 or so attempts, though, the connection tends to be fine. (After trying several times tonight, I've now been connected, quite happily, for about 20 minutes.)

No problem with ISP or phone line - got PC in the house, using same ISP - it connects first time and stays connected.

Any suggestions?


  • Reply 1 of 8
    Just the obvious suggestions.

    Try a different phone cable. Try using the same one used to connect to with the PC.

    Try connecting with the iBook from a different location. If it works well this would verify that the iBook is working properly.

    My guess is that it is the wiring or the line. You say the line is good. How do you know? Do you have any special services? In the US we have "call waiting". If someone calls you while you are using the line you hear a click on the line and have the option to switch over and speak to the new caller. Needless to say, this plays havoc with modems.
  • Reply 2 of 8
    defiantdefiant Posts: 4,876member
    they seldom come back..
  • Reply 3 of 8
    Who or what seldom comes back?

    The line is fine - there are 2 PCs in the house, using the same ISP. No problems.

    Tried connecting the iBook with another ISP today. Seemed to work much better.

    Something I don't understand is preventing Mac OS X 10.1 from connecting properly. My ISP clearly doesn't like OS X...

    Why should that be? I know nothing about "modem scripts" and the like. It's bewildering.

    What things are relevant here that I don't understand? (A friend said something about INIT scripts, I think.)
  • Reply 4 of 8
    defiantdefiant Posts: 4,876member
    [quote]Originally posted by Fray Bentos:

    <strong>Who or what seldom comes back?</strong><hr></blockquote>

    those who ask a question. you are different, though.
  • Reply 5 of 8
    I'm running on a DSL line here, but I visited some family in San Francisco a while back and had to use the 56k Modem on my PowerBook G4 to get my e-mail while I was there, and I ran into the same problem. Do you get the error message saying that "connection lost because the other side is not responding"? I tried a couple of different access numbers at first, but that really didn't seem to matter, so I went into the Internal Modem setup in the Network System Preference pane. I tried toggling TCP header compression on and off (as well as some others, but I can't remember what they were - I'm running Jag, and they've totally changed the way the window looks...) Anyway, try turning that feature on or off, (whatever it isn't right now) and make sure to quit the System Preferences application before you try to connect again.

    Good luck with that - it seemed to help me because after a few days of fiddling, it stopped acting up and actually worked... 10.1 has always had issues with connecting via modem, so I hope they fixed it in 10.2...
  • Reply 6 of 8
    "connection lost because the other side is not responding"?

    Yes. That's exactly it.

    I haven't tried fiddling with the things you mention (though I will).

    Apparently, the alternative ISP is behaving no better.

    Why should this be?

    "10.1 has always had issues with connecting via modem, so I hope they fixed it in 10.2"

    Jesus. Why can't Apple get their act together? Is this a trivial thing?

    My flatmate's iBook is driving her up the wall - unless you have the patience of a lunatic, the Internet is unuseable.
  • Reply 7 of 8
    der kopfder kopf Posts: 2,275member
    I had the exact same problems with my PwB G3 bronze. It would first not even connect for five to six times and then it would drop the connection after three minutes. Not even checking my mail was possible: mostly it would drop dead on me in the middle of some attachment.

    I always thought it was because I have to put a prefix before the ISP's number to get the 'outside line', or the fact that the incoming line is ISDN (although I'm on the telephone wire of an analog phone, as far as I know).

    Now, for one thing: I think I read that Apple suggests using the v34 modem script (System Preferences&gt;Network&gt;Modem&gt;Modem -Apple Internal 56K Modem (v. XX)), if available.

    The reason being the following: it negotiates a lower bandwidth by default (34000 bytes), which, apparently, gives less rise to errors.

    So those of you still stuck with 10.1.x, maybe you could try that and let something know if it works...
  • Reply 8 of 8
    sorry, wish i'd read this before.

    that suggestions is exactly correct, i've run into this on lines that have static/noise on them before. the other option you have to is try the v.92 settings, as i believe it will negotiate the settings you need for you.

    a few things you might want to try.

    1. another computer on the exact same phone jack. see if it has the same problems.

    2. plug your machine into a different phone jack, see if it still has problems.

    3. (this one can be a bit of work) try connecting from another house to verify if it your hardware (computer) or hardware (phone lines). if your machine works fine in another location, it's your phone lines. same problem and it's most likely your machine.

    4. (this is after your find out the problem is your phone line. if it's your machine, skip this step)

    call up your phone company and say that you're hearing a lot of hissing on the line on your end with multiple phones. ask them if they can take care of the noise on the phone. the telecom company where i used to work would try to reduce line noise whenever possible, but people actually have to call in. otherwise they never notice.

    if they can cut down on the line noise your connection speed will likely jump back up.

    let me know how those go.
Sign In or Register to comment.