I think the Firewire died on my hard drive

in Genius Bar edited January 2014
A couple days ago I got an external 20gb bus-powered usb/firewire hard drive. Unfortunately I'm already having a problem with the drive. Today I brought it over to my friend's house, plugged it into his G4 (running OS 9.2) through firewire, copied a few files off of it, unmounted it and unplugged it. 15 minutes later (in OS 10.2 now) I plugged it in again and it spun up and the r/w light lit a couple different times, but the computer just freezes for about 10 seconds and then doesn't mount. If I look at the CPU monitor, it shows heavy system processes until I shut the drive off (then they immediately disappear). It isn't recognizable in Disk Utility or System Profiler either. After that I tried it on 2 other computers and with a few different cables, both in OS 9 and X, with no luck. I also tried it with USB and that did, in fact, work fine, but I can't get it to work with firewire. Any idea what I can do to fix this??
Sign In or Register to comment.