Finder never showing contents for some folders...

Posted:
in macOS edited January 2014


Plugged a thumb drive into this iMac (10.6.4 2.26GHz Core 2 Duo Aluminum 2GB). Opened a folder and sub-folder I wanted. Fine.


 


But many other sub-folders on that drive never open. At the bottom right of the Finder window, the little symbol keeps spinning and spinning endlessly. Nor can I Get Info-never opens. The folders have few contents inside, not photos or movies or anything. 


 


I can copy the never-opening folders to the hard drive, but I'm bugged why this is happening.


 


Tried to eject, and get "The disk "ABC" wasn't ejected because one or more programs may be using it. That is untrue, I went so far as to close Word etc. 


 


I believe this worked fine on MacBook and PC...tried Force Eject to check but that doesn't even work...gonna post this and shut down.


 


???


 


P.S. This is not an admin login, but if I click the drive it says I can read and write. I can't check the problem folders because I can't Get Info.

Comments

  • Reply 1 of 1
    pbpb Posts: 4,232member


    It looks like your drive may be damaged. Have you tried Disk Utility to see if it can read it? Also, if you have another computer, you can try to read it there. If it is still unaccessible, then there is definitely some kind of damage.

Sign In or Register to comment.