Terminal problem in OS X

Posted:
in Genius Bar edited January 2014
Okay, so I've been using a command line program called TinyFugue for all my telnet needs. By opening the document provided in the package, it automatically launches the terminal and runs the app in the shell.



Normally, this is fine. If I launch Terminal by itself, I get a command prompt. Open the document, I get Terminal running TinyFugue.



However, after downloading the 10.2.4 update and repairing permissions, Terminal automatically runs TinyFugue. I can't get to the command line!



Somehow, the script contained in the TF document has wormed its way into Terminal's startup routine. So, my shell starts up TF every time I create a window in Terminal. Where can I find the file that Terminal uses for default commands at startup? I'd like to get my command line back.

Comments

  • Reply 1 of 5
    dobbydobby Posts: 796member
    It might be a defaults setting.

    Do a defaults read from the. Shit, I see your problem.

    Have you tried another user?





    Cheer Dobby
  • Reply 2 of 5
    keshkesh Posts: 621member
    [quote]Originally posted by dobby:

    <strong>It might be a defaults setting.

    Do a defaults read from the. Shit, I see your problem.

    Have you tried another user?</strong><hr></blockquote>



    No, but that's a good idea. I'll have to set up another admin user... Thanks for the idea.
  • Reply 3 of 5
    elricelric Posts: 230member
    Open terminal then preferances, you should see a text box that has '/bin/tcsh' in it. I am guessing that it might have tf listed in there instead. BTW which muds do you play?
  • Reply 4 of 5
    I had this problem, but with top.



    Trash terminal pref....
  • Reply 5 of 5
    keshkesh Posts: 621member
    [quote]Originally posted by Elric:

    <strong>Open terminal then preferances, you should see a text box that has '/bin/tcsh' in it. I am guessing that it might have tf listed in there instead. BTW which muds do you play? </strong><hr></blockquote>



    Nope. It's set to 'default', but even if I change it to the '/bin/tsch' setting, I still get TF.



    Turns out that trashing the Preference worked. However, the fun part was figuring out what file that was! On a hunch, I tried:



    com.apple.Terminal.plist



    ... which worked. I can now use Terminal normally, and TF still works just fine when launched seperately.



    Oh, and I don't visit any MUDs at the moment. Just a couple MUCKs some friends hang out on, so I can chat.
Sign In or Register to comment.