Getting permissions errors when restoring documents from Time Machine

in Mac Software edited January 2014
Hi. I am using an IMac running system 10.8.5. I am also using Dropbox version 2.4, which is the latest version.


I posted a message about this issue on Apple's forums earlier this year, but I never got a satisfactory response so I thought I'd post here. 


My situation is this:


I have about forty folders in my Documents folder. One of the folders is my Dropbox folder. The Documents folder, and all the folders in it, are backed up to an external drive using Time Machine.


My problem is that when I've tried restoring some files from those folders using Time Machine, I get a permissions error. Specifically the error is: "The operation can’t be completed because you don’t have permission to access Name-of-file"-- where "Name-of-file" is the name of the specific file I'm trying to restore.


After I started getting the error, I tested restoring documents from most of the forty folders within the Documents folder and most restored fine, but I had errors with many, but not all, of the files in the Dropbox folder.


I also use a program called Scrivener and put most of its documents (the ones that aren’t in my Dropox folder) in a Scrivener Docs folder.  The files in the Scrivener Docs folder also resulted in permissions errors when I tried restoring them from Time Machine.


I am the only person who uses my Mac and I've never manually restricted the permissions of any of the files. I'm also able to open, edit and save the latest versions of those files with no permissions errors. And I've looked at the Get Info panel for the different files in my Documents folder and I don't see any differences that would indicate why I'm getting errors with some files and not others. 

Does anyone know what might be going on?


Because of this error, I have to be very careful never to choose Replace when restoring from Time Machine. When I do that and I get the error, Time Machine deletes the current version of the file and replaces it with a version that has an error and is unopenable.











  • Reply 1 of 2

    Hi again. Just some other info that might be useful:


    When I try to manually drag some files from my Time Machine backup to my main hard drive, I get a message saying:



    An error occurred. The operation couldn't be completed (OSStatus error -54.)"


    However, I googled "OSStatus error -54" and I couldn't find out what it means.


    It's tricky, though: I got that error with some files that I am able to restore with Time Machine. So I don't know if that error relates to the problem I described in my previous post.





  • Reply 2 of 2
    MarvinMarvin Posts: 14,208moderator
    Error message are listed here:

    "error -54 permErr: permissions error (on file open)"

    If you didn't already do this, be sure to put quotes around items that have a minus sign in Google because otherwise Google sees the minus as excluding that term from the search.

    The dropbox folder tends to have different permissions from other folders as it's write-only to people dropping things in it. Files put in there should be copied out.

    Permissions problems are not problems that mean files are inaccessible permanently, you can change permissions. Sometimes the Finder lets you do this under "sharing and permissions" in the Get Info panel but sometimes that doesn't work consistently. The quickest route to making a file able to be opened is to use the terminal in /Applications/Utilities/Terminal. You type in:

    chmod 777 drag-file-in-here

    Once you drag the file in and hit return, it will ask for the admin password (assuming you are logged in as an admin) and the file should open and save ok. Don't do this for everything you come across and not for special folders like Dropbox, just use it on files that won't open because of permissions. You can do it recursively if you have a lot of files but you have to be careful with that.

    You can also use Disk Utility in the utilities folder to verify that your permissions are set ok on all your folders in case this is adding to the problem.
Sign In or Register to comment.