Safari flaky in Mavericks

in Genius Bar edited October 2014

Since downloading the update last night on 3 different machines...2009 iMac, 2011 iMac, and 2012 Mac Pro...safari has been very flaky. The initial page loads fine, but clicking on subsequent links sometimes goes into la-la land. Also, clicking on links in my bookmarks bar often send it into la-la land. Anyone else having this issue?


note: I have uninstalled any third party plug-ins.


  • Reply 1 of 10

    Think it's finally working properly. Required a complete reinstall of Mavericks, java and flash.

  • Reply 2 of 10

    So… Java and Flash were responsible. Not Mavericks or Safari.

  • Reply 3 of 10

    Can't really confirm. It didn't work just by reinstalling Mavericks. It took reinstalling all of them. I did spend time on the phone with Apple support, and they did confirm there were a few known issues that they are working on, so I would say everyone is a culprit.


    But, hey, it's a brand new release...I wasn't expecting perfection.

  • Reply 4 of 10

    OK. I spoke too soon. Still doing the same thing, just less often. Some subsequent links send it into la-la well as any preference adjustments (like reset safari, private browsing, etc).


    Guess I'll just have to live with it until they patch it.


    UPDATE: I've stumped Apple tech support. They have agreed it is a safari issue, and have passed my capture files up to Apple Engineering to see what is going on.

  • Reply 5 of 10

    dare I ask?:


    What, exactly, is "la-la land"?  Are you being forwarded to is Safari crashing?... is the entire machine hanging?... are you entering a transcendental state? 


    I'm just curious what the problems actually are that I should be wary of when I upgrade.

  • Reply 6 of 10

    Well, I guess la-la land wasn't a very technical description.


    Safari doesn't "hang" in the sense that you have to force quit it. I can close it out regular. But the page goes blank and gives the spinning wheel. If you use any safari preference (reset safari, private browsing, etc), the preference window grays out when you click the "ok" button, but the preference doesn't change...if that makes sense.


    So say I select private browsing....the private browsing message window turns gray, the window doesn't close, private browsing is not initiated, and you have to close out safari...but you can close it out the regular way. No forced quit is required. Same thing with any other preference change.


    As far as browsing, every initial page loads fine. But about 50% of the time if I click on a sub-link contained in that page it goes blank and get the spinning wheel.


    It's just weird behavior.

  • Reply 7 of 10
    marvfoxmarvfox Posts: 2,275member

    I would wait to upgrade to the Mavericks OS until all the bugs are removed completely.

  • Reply 8 of 10
    Originally Posted by marvfox View Post

    I would wait to upgrade to the Mavericks OS until all the bugs are removed completely.


    So… wait forever, then.

  • Reply 9 of 10

    Problem solved. Kudo's to the Apple Engineering staff for their assistance. Turns out the issue was with legacy preference files in my Library and Internet Plugins folder which were not automatically deleted (for some reason) during the upgrade process.


    The engineers helped me search through the library files to manually remove the old files. That fixed it.


    Thanks so much guys!

  • Reply 10 of 10

    I know your experience was over a year ago but any chance you can say anything about *which* files you had to delete?  (I just started having problems this past week.)  Thanks.

Sign In or Register to comment.