Upgraded to Mavericks, now computer powers itself off on boot.

Posted:
in Genius Bar edited January 2014

It this a known problem?  On boot I get the gray screen with the apple and the spinner, combined with a flat progress bar on the bottom.



The progress bar gets about 25% of the way done, and then the machine powers itself off.  Cmd-R does not work to put the computer into recovery mode, but target mode seems to work, and I'll get my data off the computer that way.



Computer is a 2008 Mac Pro with a 2-disk raid array.

Comments

  • Reply 1 of 3
    MarvinMarvin Posts: 14,209moderator
    The flat progress bar normally shows when a firmware update is being installed. If one is due to install, it will try and install it at boot up. There's a guide here for dealing with these:

    http://reviews.cnet.com/8301-13727_7-57585013-263/how-to-handle-os-x-firmware-updates-that-wont-install/

    "After following these steps, try rebooting again to see if the issue has been resolved. If not, remove any residual traces of past update attempts by opening the System > Library > CoreServices > Firmware Updates directory and moving any items in this folder to the desktop."

    In target mode, check if there's any firmware updates in that folder.
  • Reply 2 of 3

    unplug the RAID and do it again.

     

    My iMac with a mirrored RAID setup did something similar ... I unplugged the RAID and it finished the upgrade and ran fine.  But whenever I'd plug that (USB3 drives on a USB2 iMac) RAID array into the iMac, it would crash. (whether after or during startup)

     

    Something in Mavericks doesn't like having my USB RAID array plugged in.

     

    I fixed it by getting a thunderbolt dual-drive and copied the old USB RAID to it ... Mav works fine on that iMac with the thunderbolt array.

     

    (The old USB RAID happened to work OK on my MBAir running Mavericks... but it also has USB3 ports ... perhaps it had something to do with using the USB3 RAID on USB2 ports of the old iMac... )

  • Reply 3 of 3
    e1618978e1618978 Posts: 6,074member

    The raid array is internal, and it is my boot disk so I need access to it.   I can't boot in safe mode, can't switch boot disks, and when I boot in target mode the other computer can't mount the raid array either, just the other two non-raid internal disks.



    Right now my plan is to copy a boot image to a non-raid disk in my computer, and pull the raid disks out to force the computer to boot from the non-raid disk.  Once that works I will plug the raid disks back in and see if I can copy the data off.

     

    [ which worked, thanks all, now fully upgraded to Mavericks ]

Sign In or Register to comment.