Canon Printer vs. The iBook Of Doom!

in Genius Bar edited January 2014
Wasn't sure where to post his thread, but here goes:

I have a Canon S600 printer and I am trying to use it with my iBook (800 mhz). I haven't had any luck. I installed the drivers, the computer sees its there, but when I try to print something, it says "printing has stopped, would you like to continue?" I click continue, but nothing happens. I dumped the drivers and tried it that way... no dice. Reinstalled the drivers... nada. And yes, it is plugged into my machine and turned on! I've checked what I think are the obvious problems. Anyone have any advice? I have heard rumors Canon drivers aren't all that great. I know I'm still having trouble with my Lide 30 scanner working properly... but thats a whole other thread.


  • Reply 1 of 3
    If you are using Mac OS X, you could try these drivers:
  • Reply 2 of 3
    trebuchettrebuchet Posts: 176member

    Originally posted by Haddock.

    If you are using Mac OS X, you could try these drivers:

    Thanks. I'm checking them now.

    Edit: My Canon S600 is not supported... damnit.
  • Reply 3 of 3
    trebuchettrebuchet Posts: 176member
    Update: Got the printer to work. I deleted the drivers I downloaded adn re-downloaded them just to see if it would make a difference. I also noticed that you are supposed to delete the printer from the list of printers in Print Center. Maybe I should read the instructions carefully next time Really, the instructions for the drivers are so goofy. If you open up the instructions and are reading them, you're already on step 4. So... I already made it through step 1-3??? Yeah, I did. Anyways, been printing away.

    So, if you have Canon driver problems, this may help. Before installing the OSX drivers from the Canon site, delete whatever printer name you have on the list in Print Center, then install and restart. Worked for me.

Sign In or Register to comment.