iPhone 4s hangs during restore

in Genius Bar edited January 2014

I have an iPhone 4S GSM that I needed to restore to complete an unlock. When I tried to restore, both my Mac and PC gave me an error message that the iOS 7.0.4 download was corrupted and that I needed to download again. I downloaded the IPSW as a separate file and tried to restore directly from the file. The restore hung and I aborted it but I obviously can't use my phone until the phone is restored. I have tried the restore process on both my Mac and PC running the latest version of iTunes on Mac OS Mavericks and Windows 7 respectively and it hangs at the same spot. I have tried the restore with different USB cables and ports. Does anyone have any suggestions as to what else I can try? I am pulling my hair out here because my phone was working perfectly prior to this issue.


Update: Since posting, I have managed to get the restore to a further point the process, at which point it hangs again.

Sign In or Register to comment.