Library/Extension file.

in macOS edited October 2014

I have an iMac using OS 10.7.5.  This morning I attempted to install two current updates - one relating to iTunes, the other to a Canon printer I installed for the first time earlier in the week.  Having begun the process I received a message to say the update could not proceed because "The 'System/Library/Extensions/AppleUSBEthernetHost.kext' file was installed improperly and cannot be used.  Please try reinstalling it or contact the product vendor for an update"  It was installed and last opened in January 2012 and doesn't seem to have caused a problem before.  What am I meant to do?  Incidentally the two updates were installed without any further comment, it would seem!


  • Reply 1 of 8

    Hello All-

      I had the AppleUSBEthernetHost.kext problem when downloading iTunes 11.4. This is a widespread problem, many forums have addressed it.

    I found help here:

    See Lanny’s post, I did as he suggested.

    1st- Close iTunes.

    2nd- Delete the system extension “AppleUSBethernetHost.kext” from here:


    3rd- go to iTunes 11.4 download, here:

    click on the Download Now link.

    4th- Find the downloaded iTunes11.4.dmg file, open it, now open the Install iTunes.pkg

      After the re-install as above I got the successfully installed window and no “pop up”

    improperly installed AppleUSBMultitouch.kext warning window.

    My System:  27" iMac 2.8 GHz Quad Core i7; 8 GB DDR3 SDRAM 2x4; 2 TB Serial ATA Drive; ATI Radeon HD 4850 Graphics with 512 MB; Using 10.9.4 Mavericks. AudioEngine A5's

    Later, Robes

  • Reply 2 of 8

    Thank you, Bob, for your response to my query.  Not only was it clear, it was within my capability and it worked!  So far so good!

    Many thanks

  • Reply 3 of 8

    Oh my gosh this error message was killing me!!  All the other posts made it so difficult to figure out, and I am not a computer nerd, but I can usually get a task done. Your instructions were very clear, simple and easy to follow.  Thank you for helping me get rid of that annoying message!



  • Reply 4 of 8

    I am having trouble with that .kext also. I followed the suggestions and the link but the iTunes 11.4 download comes as .dmg.part and won't open. I even tried renaming without the .part and that didn't work either. What now?

  • Reply 5 of 8



    It sounds like the .dmg file did not completely download. I suggest you try the download link again and look for a file that does not have ".part" appended to the name. That should open and install OK for you.

  • Reply 6 of 8
    jenodjenod Posts: 1member

    I received this message when I tried to do a system update.  I went to Library and don't have an option for extensions.  Any clue?  

  • Reply 7 of 8

    You may be looking in the wrong Library folder. Make sure you're looking in the one that's inside the System folder, not the Library folder that resides on the same HD listing as your System folder.

  • Reply 8 of 8

    Very helpful, thank you!

Sign In or Register to comment.