MacBook Air running slow after upgrade to Yosemite

in macOS edited December 2014

I've had the same problems as most of the users that are having problems. My fix was to turn off bluetooth altogether, and hookup a wired mouse (she doesn't like to use the trackpad) to my wife's Macbook Air. This solved my problem! Now she's back with a fast running Yosemite. 

I guess we'll just have to wait until Apple puts out a fix......


  • Reply 1 of 2

    Thank you!


    I turned off bluetooth and I am amazed! My Mac Air is so much faster!

    Wasn't using bluetooth for anything anyway.


    Very happy!

  • Reply 2 of 2

    Bluetooth has far more reaching effects than just wireless keyboards and mice anymore, so it stands to reason that it's going to start being the root of issues, I suppose.


    I used to turn it off to save battery life on laptops/iphones. But anymore, the phones and computers use them to sync with each other, my car, my computers, etc. It's to the point where the option to turn it off might as well not even be there for me.

Sign In or Register to comment.