Safari - Google Search Not Working (OS X)

Posted:
in Genius Bar edited November 2015

Whenever I enter a search, the search terms move to the upper left corner as if it is working, but no search results ever appear.

 

When I go to Firefox, all is well.

 

??????

 

Thanks All !

Comments

  • Reply 1 of 7
    joshajosha Posts: 901member
    Quote:

    Originally Posted by hledgard View Post

     

    Whenever I enter a search, the search terms move to the upper left corner as if it is working, but no search results ever appear.

     

    When I go to Firefox, all is well.

     

    ??????

     

    Thanks All 


    Google is spyware !

     

    I recommend you use DuckDuckGo for searches.

    It works well  and doesn't spy on you.

  • Reply 2 of 7



    But still, I have really liked Google search and am used to it.  There is some odd problem, somewhere.

     

    Any ideas anyone???

  • Reply 3 of 7
    gatorguygatorguy Posts: 23,393member
    hledgard wrote: »

    But still, I have really liked Google search and am used to it.  There is some odd problem, somewhere.

    Any ideas anyone???
    Was this only in the last day or so? What browser? I noticed something along those lines too but working great now. No idea what it was but seems to have corrected itself.
  • Reply 4 of 7
    Seems OK now. Installed El Capitan.

    Thanks to all of you !

    I appreciate this forum ! !
  • Reply 5 of 7
    indiekidukindiekiduk Posts: 368member
    It happens to me after waking from sleep on El Cap. Everything works except google search in Safari, even in a new tab. Quitting and relaunching fixes it, but its a real pain. My guess would be its either DNS, SSL or Google's load balancing causing the problem. 
  • Reply 6 of 7
    hledgard said:

    Whenever I enter a search, the search terms move to the upper left corner as if it is working, but no search results ever appear.

     

    When I go to Firefox, all is well.

     

    ??????

     

    Thanks All !

    Yes, I had this problem too. Google search just did not work for me any more in Safari on iMac.

    (the iMac is also running Windows 10 as a virtual machine & that browses Google just fine, using MS Edge)

    Searching on Bing, I discovered that 'no Google on Safari' seems to be a very common problem & has been recurring with users for many years now.

    I found another post advising that afflicted users should 'log-out of their Google account'

    On checking I discovered that  I was 'permanently logged-in' to my Google account. 

    Hey-Presto - on logging-out I discovered that I was once more able to search Google using Safari.

    Maybe this suggestion may also help other.

    Best Regards,

    Microchips

    edited March 2016 gatorguy
Sign In or Register to comment.