How do you block or stop iPhone from changing wifi network on iPad

in Genius Bar
Hi, I am having a problem I just can't seem to solve. I have a Wi-Fi modem in my living room that covers one side of the house and I have a Wi-Fi extender in the office that covers the other side of the house. Because the modem won't cover the whole house.The problem is if we are using the iPhone and iPad in the office hooked to the "Extender" and Everything is working great. The problem is when the iPad stays where it is and you take the iPhone in the living room and hooked up to the "Main modem". The iPad also switches and hooked up to the "Main modem".  Which makes the iPad stop working because the signal is so weak now. How do you stop the iPhone from changing the iPad Wi-Fi network when you move the iPhone and hook up to a different Wi-Fi network. I tried making the SSID the same on both the modem and Extender hoping that would fix the problem. But that made it worse because the iPad would still try and connect to the same device the iPhone was hooked to and now because the SSID was the same on both modem and extender I had no way of rehooking the iPad to the extender that is 5 feet away from it and has full signal. I also got both "Personal Hotspot" shut off on both devices. I also clicked "Forget this network" on all wifi networks except the Extender. But as soon as I log onto another wifi network on the iPhone and put in the password the iPad also connects. I need a way to block the iPhone from changing the wifi network on the iPad or an option to set the wifi priority on the iPad. I can't believe there is no option to do that. Every time the iPhone connects to a different wifi network I have to manually go into the iPads setting and change it back to the only wifi network it should and has always been hooked to. This problem only started since I updated to the latest IOS version. Anyone know how to stop this from happening. Someone suggested to disable iCloud Keychain but if I do that I loose all the iCloud Keychain function and that is only a bandaid fix. Anyone else have a better fix. Thanks for any help you can provide.
Sign In or Register to comment.