How to ditch bad Wi-Fi info so Apple Watch Series 3 with cellular has better connectivity

Posted:
in Apple Watch edited September 2017
The Apple Watch Series 3 with LTE has a bug related to how it decides to stay on shoddy Wi-Fi, or shift to LTE. This can be remedied somewhat by cleaning up your known networks and not connecting to the some bad Wi-Fi hotspots in the first place -- here's how to do it.




This won't be the ultimate fix to connectivity with the LTE Apple Watch, but it will improve the situation dramatically until Apple rolls out the software patch.

The most precise way to eradicate errant Wi-Fi network login information on your iPhone is actually done from your Mac -- assuming you've got iCloud Keychain synchronization on. There is another way to do it from your iPhone or iPad, but it is a little more drastic and we'll cover it at the end.

First, the precise way.

Set up iCloud Keychain on your Mac

Select System Preferences and click iCloud.




Toggle Keychain on if it isn't already.




The Mac will prompt you to enter your Apple ID and Password. If you already have the feature on, other devices will ask permission to add the new device.

Then, set up iCloud Keychain on your iPhone or iPad

Select Settings, and tap on your name. Tap iCloud




Tap Keychain and turn on iCloud Keychain.




If your Mac was the first device to enable the iCloud Keychain, it will ask you for permission to add your iPhone or iPad to the list of authorized devices. If two-factor authentication is on, the iCloud Keychain can be turned on without approval from the other device.

Purge the bad base stations

On your Mac, in Settings, choose Network.




Select Wi-Fi, then click the Advanced button.




There are probably a wide assortment of Wi-Fi networks here to choose from. Delete any and all of them that you don't immediately recognize. The changes will propagate across the iCloud Keychain to the other devices.

The more dramatic option

If you're not so inclined to prune your known Wi-Fi network list, or it's just time for a clean sweep, the process is simple on iOS.

Select Settings, and tap on General. Scroll down, and tap on Reset




The next step will eradicate all wi-fi passwords from the iPad, and your iCloud Keychain if you're synchronized. Be sure you have the password for your network that you're currently connected to before you move to the next step!

Select Reset Network Settings and enter your passcode.


longpath

Comments

  • Reply 1 of 18

    I am glad you pointed this out, this is not just a Watch 3 issue, I had this issue on my phone.

    I have Xfinity and they offer free hotspots which essential using someone home routers wifi, they steal their users wifi and internet bandwidth to give the other customers free wifi. With this my phone has connect to hundred of Xfinity hotspots and some of them had really poor connection but the phone would not drop them. I had to go in and clear these off so they would not automatically connect.

    I suspect Apple go caught by this since they testing in house and they wifi is much better than the crap around big cities. The evaluators probably had lots of marginal wifi listed in their connection history and the watch tried jumping on them. Not sure how Apple fixes this.

    jahbladeGeorgeBMac
  • Reply 2 of 18
    One of the things that drives me absolutely crazy about the iPhone is how it holds on to Wi-Fi networks with a weak signal and network connectivity just fails. It won’t switch to LTE but the Wi-Fi signal is too weak for anything to work. So I have to manually turn off Wi-Fi and wait for it switch over. It’s been this way for years.  I don’t understand why iOS doesn’t drop these weak Wi-Fi signals sooner or at least give the user a setting to drop Wi-Fi and switch to LTE when signal strength is less than x. 
    SoundJudgmentstanhopeGeorgeBMacredgeminipa
  • Reply 3 of 18
    cpsrocpsro Posts: 2,462member
    maestro64 said:

    I suspect Apple go[t] caught by this since they testing in house and they wifi is much better than the crap around big cities.

    Aside from the red dot on production models that shouldn't have been present on test devices, the Watch Series 3 looks identical to the Series 2. Apple employees should have had no difficulty discretely testing the Series 3 anywhere. Cupertino is also Comcast Xfinity territory.
    edited September 2017 redgeminipa
  • Reply 4 of 18
    robbyx said:
    One of the things that drives me absolutely crazy about the iPhone is how it holds on to Wi-Fi networks with a weak signal and network connectivity just fails. It won’t switch to LTE but the Wi-Fi signal is too weak for anything to work. So I have to manually turn off Wi-Fi and wait for it switch over. It’s been this way for years.  I don’t understand why iOS doesn’t drop these weak Wi-Fi signals sooner or at least give the user a setting to drop Wi-Fi and switch to LTE when signal strength is less than x. 
    Am I wrong, but didn't they add that in IOS 10, when a wifi network goes to bad speed, it automatically switched. Obviously needed to turn it on, but didn't it even start a controversy last year?
    racerhomie3
  • Reply 5 of 18
    dws-2dws-2 Posts: 238member
    robbyx said:
    One of the things that drives me absolutely crazy about the iPhone is how it holds on to Wi-Fi networks with a weak signal and network connectivity just fails. It won’t switch to LTE but the Wi-Fi signal is too weak for anything to work. So I have to manually turn off Wi-Fi and wait for it switch over. It’s been this way for years.  I don’t understand why iOS doesn’t drop these weak Wi-Fi signals sooner or at least give the user a setting to drop Wi-Fi and switch to LTE when signal strength is less than x. 
    Am I wrong, but didn't they add that in IOS 10, when a wifi network goes to bad speed, it automatically switched. Obviously needed to turn it on, but didn't it even start a controversy last year?
    Yes, Apple tried to more aggressively switch to cellular. They got sued for wasting people's data. It just goes to show that you're going to make someone mad no matter what you do. 
    jahbladeGeorgeBMacairnerdpeterhart
  • Reply 6 of 18
    robbyx said:
    One of the things that drives me absolutely crazy about the iPhone is how it holds on to Wi-Fi networks with a weak signal and network connectivity just fails. It won’t switch to LTE but the Wi-Fi signal is too weak for anything to work. So I have to manually turn off Wi-Fi and wait for it switch over. It’s been this way for years.  I don’t understand why iOS doesn’t drop these weak Wi-Fi signals sooner or at least give the user a setting to drop Wi-Fi and switch to LTE when signal strength is less than x. 
    Yeh,  My driveway is the worst!   Once I pull out of the garage and stop in the driveway its still connected to my home WiFi, but its too weak to do anything....   So, I sit there waiting for Apple Music to come up with a list of songs for me.   (You can't drive without tunes!)
    redgeminipaairnerd
  • Reply 7 of 18
    dws-2 said:
    robbyx said:
    One of the things that drives me absolutely crazy about the iPhone is how it holds on to Wi-Fi networks with a weak signal and network connectivity just fails. It won’t switch to LTE but the Wi-Fi signal is too weak for anything to work. So I have to manually turn off Wi-Fi and wait for it switch over. It’s been this way for years.  I don’t understand why iOS doesn’t drop these weak Wi-Fi signals sooner or at least give the user a setting to drop Wi-Fi and switch to LTE when signal strength is less than x. 
    Am I wrong, but didn't they add that in IOS 10, when a wifi network goes to bad speed, it automatically switched. Obviously needed to turn it on, but didn't it even start a controversy last year?
    Yes, Apple tried to more aggressively switch to cellular. They got sued for wasting people's data. It just goes to show that you're going to make someone mad no matter what you do. 
    ... Especially if your name is "Apple"!
    .....   Perfection please.  Not just the first time, but everytime!
    ............  And no stinkin' trade-offs either!
    airnerd
  • Reply 8 of 18
    The XFiniti hotspot makes a LOT of sense!
    ...  I refuse to connect to them anymore -- not for this reason but because I would find my phone connecting to those essentially unsecured spots rather than to my preferred, known WiFis.
    redgeminipa
  • Reply 9 of 18
    Good tip!

    Using the 'Mac' method, you can also re-order your networks, placing the preferred ones on top.  I've had to do that to help prevent my Mac, when at work, from choosing a public SSID over my work's private LAN SSID.  It so happens this public SSID is generously located in most retail and public places in my city, so I'm normally happy to connect to it, just not at work.

    It's too bad that:

    a) you can't prune and re-order networks directly on your iOS device (not everyone has a MacBook, and the reset network settings in iOS is a pretty 'big hammer' solution)
    b) that iOS and macOS don't just analyze the utilization of SSIDs, also taking into account the device's location, and just auto-sort the SSIDs into a preferred order list - maybe even letting you promote favorite SSIDs to always take precedence over the auto-sorted list.

    Yes, I've submitted both ideas to https://www.apple.com/feedback/
    edited September 2017 GeorgeBMacracerhomie3
  • Reply 10 of 18
    cpsro said:
    maestro64 said:

    I suspect Apple go[t] caught by this since they testing in house and they wifi is much better than the crap around big cities.

    Aside from the red dot on production models that shouldn't have been present on test devices, the Watch Series 3 looks identical to the Series 2. Apple employees should have had no difficulty discretely testing the Series 3 anywhere. Cupertino is also Comcast Xfinity territory.
    Actual Apple has gotten caught testing unreleased product in the wild. The produce ID show up in network access logs then people will know it is coming. Also it could have been the users who were testing did not have all the crap network lists in their phones.
    GeorgeBMac
  • Reply 11 of 18
    jfc1138jfc1138 Posts: 3,090member
    In the WiFi section of my iphones settings I can set to ask to join and edit to “forget” selected networks. If this propagates to my watch all the unknown “bad” hotspots should be ignored?

    otoh Ones I use that require repeated acceptance of terms before completing the login I gather will confuse the watch. 
  • Reply 12 of 18
    techrider said:
    Good tip!

    Using the 'Mac' method, you can also re-order your networks, placing the preferred ones on top.  I've had to do that to help prevent my Mac, when at work, from choosing a public SSID over my work's private LAN SSID.  It so happens this public SSID is generously located in most retail and public places in my city, so I'm normally happy to connect to it, just not at work.

    It's too bad that:

    a) you can't prune and re-order networks directly on your iOS device (not everyone has a MacBook, and the reset network settings in iOS is a pretty 'big hammer' solution)
    b) that iOS and macOS don't just analyze the utilization of SSIDs, also taking into account the device's location, and just auto-sort the SSIDs into a preferred order list - maybe even letting you promote favorite SSIDs to always take precedence over the auto-sorted list.

    Yes, I've submitted both ideas to https://www.apple.com/feedback/
    Well, they should AT LEAST have a preferred always connect first list for HOME and WORK (you could put as many home and work location in that bag as you want).
    Ideally a second level group that passes behind others but normally has good wifi like (favorite Coffee shops, gym, public WIFIs,etc).
    These first two you would want LTE to pass behind those WIFIS
    a third group could be a group of considered good WIFI but that you only connect if your not already on the first two on the list or on LTE.
    Then everything else are the WIFI were you want to have their connection info in the watch or phone, but will only do manual connections.


    GeorgeBMac
  • Reply 13 of 18
    robbyx said:
    One of the things that drives me absolutely crazy about the iPhone is how it holds on to Wi-Fi networks with a weak signal and network connectivity just fails. It won’t switch to LTE but the Wi-Fi signal is too weak for anything to work. So I have to manually turn off Wi-Fi and wait for it switch over. It’s been this way for years.  I don’t understand why iOS doesn’t drop these weak Wi-Fi signals sooner or at least give the user a setting to drop Wi-Fi and switch to LTE when signal strength is less than x. 
    You are literally describing exactly how the WiFi Assist feature works: https://support.apple.com/en-us/HT205296
    robbyx said:
    One of the things that drives me absolutely crazy about the iPhone is how it holds on to Wi-Fi networks with a weak signal and network connectivity just fails. It won’t switch to LTE but the Wi-Fi signal is too weak for anything to work. So I have to manually turn off Wi-Fi and wait for it switch over. It’s been this way for years.  I don’t understand why iOS doesn’t drop these weak Wi-Fi signals sooner or at least give the user a setting to drop Wi-Fi and switch to LTE when signal strength is less than x. 
    Am I wrong, but didn't they add that in IOS 10, when a wifi network goes to bad speed, it automatically switched. Obviously needed to turn it on, but didn't it even start a controversy last year?
    You're wrong only in that it was added in iOS 9. The feature is called "WiFi Assist" and it was enabled by default. It started a controversy because people on cellular plans with limited data didn't understand why their iPhones were using so much data. It ws because they have crappy WiFI and they didn't understand what WiFi Assist was doing (or even that it was enabled.)
  • Reply 14 of 18
    So my phone doesn't do this because I have toggled off the "ask to join networks" option, I am on unlimited data so I don't want to deal with crappy wifi networks.  When I'm someplace that I want to be on wifi I can easily join at that time.  

    Does the Watch not have the same option?  I'll just set it to know my trusted networks at my house, work, and family and let everything else stay on LTE...if that's possible.  I'll know more this afternoon when I get home and unbox that beautiful 42mm AW3LTE.
  • Reply 15 of 18
    I'm thinking that there's more coming on this.  That we're seeing just the tip of an iceberg (but maybe a good, kind iceberg).

    Comcast and, I think, AT&T have been (for reasons I don't understand because neither has ever been accused of being altruistic) pushing free remote WiFi hotspots for people to connect to instead of using cellular.   Now, Apple is getting caught by connecting to those hotspots -- even when their performance is unacceptable.

    This seems like two giants banging heads.  Something needs to change.
  • Reply 16 of 18
    dcgoodcgoo Posts: 213member
    maestro64 said:

    I have Xfinity and they offer free hotspots which essential using someone home routers wifi, they steal their users wifi and internet bandwidth to give the other customers free wifi. 


    Its actually not QUITE that bad. The Xfinity hot spot network is completly isolated and firewalled off from from the personal traffic in your home. If comcast's network interferes with your own network, you can ask them to turn it off completely, or buy your own modem without any wifi (that is what I did).  But it does not impact your own bandwidth subscription in the slightest and is on a completely separate network.  

    Although I do think it is a bit presumptuous of Comcast to use their equipment, that you are renting from them, to serve other customers. But then Comcast is all about presuming. 
  • Reply 17 of 18
    Just wanted to come back and say that resetting the network settings worked.  All of the unsecured wifi networks that I have at some point added over the years were wiped and since I have "ask to join wifi" turned off my phone never now recognizes them.  My watch is now able to get the cell coverage dots.  
  • Reply 18 of 18
    macguimacgui Posts: 1,264member
    If somebody does get hung up with this WiFi bug, try toggling Airplane mode On and Off for immediate relief.
Sign In or Register to comment.