Can't RDP into Mac mini running OSX 10.13.1

Posted:
in macOS
Hi,

This one has me baffled.  I recently added a new Mac mini to an otherwise all Windows & iOS LAN.  The mini is running 10.13.1 with all s/w updated.  The mini is connected to the LAN by cat6 ethernet cable with wifi disabled, and all aspects of networking are working well.

I've been unable to RDP into the mini from any platform that I've tried: Win7, Win10, iOS.  In each case, I get the "Remote Desktop can't connect..." message.  I've configured sharing on the mini to allow file sharing (which works fine), remote login (which works fine), and remote management (which doesn't work).  I've tried disabling the firewall, using the IP address instead of the mini name, restarting the mini, using wifi instead of ethernet, but no joy.  I can even RDP from the mini into the Win10 Pro machine that I'm using to type this post...

I'm using Teamviewer as a workaround but need RDP to work because of its dual monitor support on the client machine (the mini is running headless).

Is there some setting deep in the bowels of OSX that might need to be tweaked?  Thoughts on other avenues I could try?

Thanks for your help!

Comments

  • Reply 1 of 2
    sphericspheric Posts: 1,730member
    I wonder if it is affected by the Security Update in the same way as file sharing? 

    If so, this might fix it: 

    https://support.apple.com/en-us/HT208317
  • Reply 2 of 2
    Hi Spheric,

    Thanks for the suggestion!  Unfortunately one that I've tried without success.  After a lot of digging, it looks like a Microsoft RDP client running on a Windows PC can't be used to access an OSX remote machine out of the box (my bad for making that assumption, I guess). 

    Best solution I've found so far (my requirements: dual monitor RDP session from a Win10 PC into a remote headless Mac mini on the same LAN):
    • Run the nuords.com terminal server on the Mac mini
    • Add a couple dummy display emulator plugs to the back of the mini to fake it into an emulated dual monitor state
    • Fire up the standard RDP client on my Windows 10 machine and enjoy!
    cheers,
    Thrasher
Sign In or Register to comment.