So much for my dreams of speed...

in General Discussion edited January 2014
So I ordered a 1.2GHz Powerlogix upgrade for my Cube from OWC (it actually working out cheaper to get it shipped from the States to the UK than buy it direct!), and everything progressed perfectly happily with tracking numbers and all the details I needed to track its progress to the office today, where it arrived bang on time.

Great days, I thought, carrying it home and ripping the machine to bits (not for the first time) and shoving in all that raw horsepower. Put it back together, boot up, everything's just fine, XBench results up in the high 90s, ridiculously smooth graphics, fast 3D renders, silly framerates in iTunes, oh yes, I was a happy camper.

And then I noticed that none of my Firewire devices are being seen. Not my CD burner, not my external drive, not my iPod.

Pull it apart again, double-check the connections, put it back... still the same. Oh-oh, I thought, I've fried the Firewire ports (I've heard of people doing this before). So I quickly checked the availability of Cube motherboards (yes, you can get them, and dirt cheap) and resigned myself to rebuilding the machine. Ho hum...

Still, in the best fault-finding tradition, I thought I'd pop the stock 450MHz processor back in again (10 minutes all in, hell I'm good at this!), and guess what? Yes, all the Firewire works perfectly. WTF?

So I pop the 1.2GHz back in. No Firewire. Swap back, perfect Firewire. With the same devices plugged in, System Profiler shows the primary Firewire device with the 450MHz card, but not with the upgrade.

Just a teeny bit upset...

Oh well, it can go back again and I'll get another, but I'm really interested to know how the hell a problem on the processor card can chop the Firewire, since I was convinced all the bus data went through the UniNorth chip...


  • Reply 1 of 3
    matsumatsu Posts: 6,558member
    Are you missing something? A firmwar update or something, a driver issue. iDunno how any of that technical voodoo works, but that does sound wierd.
  • Reply 2 of 3
    overhopeoverhope Posts: 1,123member
    Yeah, you'd think it would be something simple, but I'm on firmware 4.1.9 (the most recent), Firewire connectivity is built in to Open Firmware (so shouldn't be able to foul up at a software level) and the upgrade is fresh out of the box: I can't find any reports of anyone else having the same problem with this card, and it's not one that every single user is going to miss!

    I'll get another card and see what transpires...
  • Reply 3 of 3
    overhopeoverhope Posts: 1,123member
    Update: I mailed Powerlogix Tech Support to see if they had any insight, and they suggested (about 20 minutes later, that's what I call service!) trying to boot off a CD and seeing if Firewire worked, but they've never heard of the problem.

    So I put the card back in again, boot her up... everything's fine.

    Okay, I thought, let's boot off the hard drive... it still works! Yay! Looks like maybe I hadn't put the Cube back together properly (d'oh), but now I'm a very happy camper.

    /me goes to play in Xbench...
Sign In or Register to comment.