Arlo delivers long-promised HomeKit support to Pro & Pro 2 cameras

Posted:
in General Discussion
Arlo has begun to roll out HomeKit support to specific models of its popular security cameras, enabling compatibility with Apple's smart home ecosystem.

Arlo security camera
Arlo security camera


Arlo on Monday pushed a new firmware out to supported Arlo Pro and Arlo Pro 2 systems, delivering promised support for Apple's HomeKit. The launch date misses an anticipated first quarter debut Arlo announced at CES 2019 in January.

With HomeKit, Arlo cameras appear right next to all other HomeKit accessories in a user's Home app, reducing reliance on the standalone Arlo app. Along with live streaming, Arlo's motion sensors can be used as triggers for other accessories, such as lights.

Apple is adding quite a few new features to HomeKit in iOS 13, some of which apply to security cameras. Some will instantly be available to Arlo users -- including those beta testing the Apple software -- such as bringing quick access to other accessories in the same room while viewing a live camera stream.

Other iOS 13 features require support from Arlo, such as the new storage feature that retains video clips within iCloud instead of on third-party servers.





The newly available update specifically applies to the Arlo Base Station and not to the cameras themselves. Firmware version 1.13.0.2_2776 is now available for the VMB4000 base station and 1.13.0.2_2777 is available for the VMB4500 model.

After updating, users will be able to access a HomeKit pairing code and add cameras in Apple's Home app.

Owners of the VMB5000 model and the corresponding Arlo Ultra 4K cameras are left waiting a bit longer for HomeKit, though it is still promised. A timeline for release has not been announced.

Comments

  • Reply 1 of 20
    pcdsimpcdsim Posts: 3unconfirmed, member
    New Firmware is 1.14 not 1.13. I’m not finding the pairing code though.
    watto_cobra
  • Reply 2 of 20
    KuyangkohKuyangkoh Posts: 375member
    pcdsim said:
    New Firmware is 1.14 not 1.13. I’m not finding the pairing code though.
    You’re right its 14....and nothing else is happening 
    watto_cobra
  • Reply 3 of 20
    smsmsmsm Posts: 8member
    Very frustrating when a company adds new features but no instructions as how to use and get the set up code needed. I wish the story had provided the needed info or a link to where Arlo is providing the instructions.

    watto_cobra
  • Reply 4 of 20
    CharlCCharlC Posts: 1member
    Hey guys,
    I'm also an Arlo user that's been awaiting this update.
    I was as frustrated as you when I saw the news, but couldn't see how to enable this. A few hours later, I noticed an app update available for the Arlo app. Once I did the update, the HomeKit functionality is now available in the app. Once you've updated, you'll find it under the Settings, there is a HomeKit section as well as in your Base Station device there is a HomeKit Setup available.

    I haven't been able to try this as you need to be on the same WiFi network as the Base Station and I'm currently at work.

    So if there is anyone out there that gets this to work, please let us know!
    watto_cobra
  • Reply 5 of 20
    mike1mike1 Posts: 1,947member
    Not holding my breath, but it would be great if they could add support to the Arlo Q cameras as well. Would buy more.
    watto_cobra
  • Reply 6 of 20
    KuyangkohKuyangkoh Posts: 375member
    CharlC said:
    Hey guys,
    I'm also an Arlo user that's been awaiting this update.
    I was as frustrated as you when I saw the news, but couldn't see how to enable this. A few hours later, I noticed an app update available for the Arlo app. Once I did the update, the HomeKit functionality is now available in the app. Once you've updated, you'll find it under the Settings, there is a HomeKit section as well as in your Base Station device there is a HomeKit Setup available.

    I haven't been able to try this as you need to be on the same WiFi network as the Base Station and I'm currently at work.

    So if there is anyone out there that gets this to work, please let us know!
    I did it today same network in all but the bridge is not recognized by HomeKit and cannot be installed.....dangit
  • Reply 7 of 20
    KuyangkohKuyangkoh Posts: 375member
    Maybe still waiting from Apples approval....it says Not recognized as accessory 
  • Reply 8 of 20
    Works really great. I am such a happy camper today. Arlo, this is a huge step in trust. I will now proceed with more camera purchases. 

    As a side note, I had to remove and reinstall my Arlo app to trigger the automatic update process. 
    watto_cobra
  • Reply 9 of 20
    I am lucky enough that Arlo firmware update was successful and added to Apple's Home app. At this time, I can see all my camera feeds in Home app. However, I haven't figured out how to get Home automation to work with Arlo... I cannot arm or disarm the system from Home app, so I cannot tie any of my scenes to Arlo. In their press release, it says "allowing users to include Arlo cameras into their custom scenes or automations." Would appreciate if any one who has figured it out to share.
    watto_cobra
  • Reply 10 of 20
    KuyangkohKuyangkoh Posts: 375member
    klock379 said:
    I am lucky enough that Arlo firmware update was successful and added to Apple's Home app. At this time, I can see all my camera feeds in Home app. However, I haven't figured out how to get Home automation to work with Arlo... I cannot arm or disarm the system from Home app, so I cannot tie any of my scenes to Arlo. In their press release, it says "allowing users to include Arlo cameras into their custom scenes or automations." Would appreciate if any one who has figured it out to share.
    Your lucky.....mine says uncertified accessory and cannot be added. How did you it? Please share
    watto_cobra
  • Reply 11 of 20
    Your lucky.....mine says uncertified accessory and cannot be added. How did you it? Please share It was really nothing to it, guess I WAS lucky. First I was at home, I remember I launch Arlo, went to Settings -> HomeKit, and it displayed the same screen as if I went to Settings -> My Devices -> Home -> HomeKit Setup (more on that later). It said Discovering your device. Please wait. And in the Device found pane, my base unit showed up, I clicked and it discovered all cameras associated with the base unit. - I did not upgrade my firmware ahead of time. I don't even know what firmware it was using before today. - Now when I click on Settings -> HomeKit, it shows an empty page except for controls up at the top. When I click on the gear icon, i shows my current home, option to add a new home, and Reset HomeKit. - I don't know if that makes a difference, I have other HomeKit accessories and I have been using HomeKit before Arlo. I hope this helps someone.
    watto_cobra
  • Reply 12 of 20
    rbtexan said:
    Works really great. I am such a happy camper today. Arlo, this is a huge step in trust. I will now proceed with more camera purchases. 

    As a side note, I had to remove and reinstall my Arlo app to trigger the automatic update process. 
    Did you get Home app to arm and disarm Arlo? If so, can you share how you did it?
    watto_cobra
  • Reply 13 of 20
    Not a real straight-forward setup. And as far as I can see, there is no interaction with the Basestation. So I can't arm and disarm with HomeKit. I just see the cameras. Also, the HomeKit setup did not propagate to other devices. So I set it up on my iPhone, but it doesn't appear in the Home app on my iPad. Everything else I've added that was HomeKit compatible propagated out. I don't think Arlo has their @&;%$ together yet...
    watto_cobra
  • Reply 14 of 20
    red oakred oak Posts: 679member
    I don’t know why I expected more from Arlo.  This rollout has been aweful  I have a Pro setup with 5 cameras

    -  I am not able to use the motion sensor of the cameras in HK app to trigger anything else in HomeKit ( eg turn on HomeKit lights).  This was really my main use case - “if detect motion, turn on an outside light’.  I must be missing something here 

    -  The cameras are not listed in accessory options when setting up an automation in HK

    -  The camera feed in HK is incredibly slow and craps out consistently after few seconds and says it cannot connect 

    -  None of my camera names carried over to HK when I set it up.  I had to find the serial numbers and rename all the cameras and sensors in HK app 

    Just aweful.  WTF Arlo?? 




    watto_cobra
  • Reply 15 of 20
    red oakred oak Posts: 679member
    They are telling everyone Q4 for Ultra 4K rollout.  I’d assume December based on their track record 
    edited August 6 watto_cobra
  • Reply 16 of 20
    Well, I take back my compliments. This homekit integration is great, but has a huge flaw. The cameras appear to stay “always on”. My battery powered cameras have lost 30 percent just in the last 5 hours. That’s not sustainable. Looks like I’ll have to figure out how to wire them up, or remove them from homekit.....
    watto_cobra
  • Reply 17 of 20
    rbtexan said:
    Well, I take back my compliments. This homekit integration is great, but has a huge flaw. The cameras appear to stay “always on”. My battery powered cameras have lost 30 percent just in the last 5 hours. That’s not sustainable. Looks like I’ll have to figure out how to wire them up, or remove them from homekit.....
    I just launched HK app, and all snapshots had a 6 hour time stamp on it. Then they are replaced by a new set of snapshots every 2 minutes if I stay on the HK app.

    It seems for each camera there are 2 entries in HK, one is the video feed and the other is camera/motion sensor itself. The video feed is on only when HK app is active, whereas the motion sensor is always on, unless you disable the camera from the Arlo app.  
    watto_cobra
  • Reply 18 of 20
    Kuyangkoh said:
    klock379 said:
    I am lucky enough that Arlo firmware update was successful and added to Apple's Home app. At this time, I can see all my camera feeds in Home app. However, I haven't figured out how to get Home automation to work with Arlo... I cannot arm or disarm the system from Home app, so I cannot tie any of my scenes to Arlo. In their press release, it says "allowing users to include Arlo cameras into their custom scenes or automations." Would appreciate if any one who has figured it out to share.
    Your lucky.....mine says uncertified accessory and cannot be added. How did you it? Please share
    REPOST since the formatting was wrong in my previous reply. 

    I WAS lucky. First, I was at home, I remember I launch Arlo, went to Settings -> HomeKit, and it displayed the same screen as if I went to Settings -> My Devices -> Home -> HomeKit Setup (more on that later). It said Discovering your device. Please wait. And in the Device found pane, my base unit showed up, I clicked and it discovered all cameras associated with the base unit. - I did not upgrade my firmware ahead of time. I don't even know what firmware it was using before today. - Now when I click on Settings -> HomeKit, it shows an empty page except for controls up at the top. When I click on the gear icon, i shows my current home, option to add a new home, and Reset HomeKit. - I don't know if that makes a difference, I have other HomeKit accessories and I have been using HomeKit before Arlo. I hope this helps someone.
    watto_cobra
  • Reply 19 of 20
    With the app update, it asked if I wanted to add Arlo basestation to Homekit. I thought I would do later but the prompt never reappeared so I had to hunt in settings. You add the Basestation as the bridge, there is no scanning of codes - it just adds after you provide permission. Then you add your cameras - Arlo app allows you to identify cameras with a flashing LED which is handy when you go to rename them for your 'favorites' screen. I would be careful of 'resetting Homekit' . I have done this with setting with other apps (Yale locks) and managed to remove ALL my Homekit devices. Overall the Arlo Homekit implementation works very well and I am happy that I finally I get to add Arlo cameras to Homekit. The images are very good and within the few hours I have played with this, the app is stable. A small annoyance remains in that the video in Homekit is 'delayed' - you see an image from a few minutes earlier but once you click on the image, it goes 'LIVE', much like the Arlo app. Motion detectors for each camera appear as a separate panel in Homekit, but you can not change any settings - that has to be done in the Arlo app. I have my Arlo Pro cameras wired via USB, so I am not affected by camera drain from cameras being on constantly. In addition to battery drain, there will likely be more bandwidth used, which is not a problem for us in our unlimited plan, but may be for others. Now I wish Ring would add as well as I think they had also announced Homekit was going to be added.  Arlo is showing Ring how to follow through...
    edited August 6 watto_cobra
  • Reply 20 of 20
    gsxgsx Posts: 1member
    I’m getting the same uncertified accessory as some others. I have the correct firmware that was listed in the story. I also have multiple houses setup in HomeKit so don’t know if that has anything to do with it or not. Also the arlo app created two temp houses in HomeKit for some reason. Seems there is a bug for some people to get this working right.
    watto_cobra
Sign In or Register to comment.