We need no "Go" button to forum jump

Posted:
in Feedback edited January 2014
Why do we need to click go after we select which forum to go to?



The user should be brought to the forum once the user clicks out of the popupmenu.

Comments

  • Reply 1 of 5
    ibrowseibrowse Posts: 1,749member
    What if they change their mind or click on the wrong one? That would suck for those on dial up to wait for two pages to load.
  • Reply 2 of 5
    defiantdefiant Posts: 4,876member
    exactly. what if you select the wrong one ?
  • Reply 3 of 5
    spartspart Posts: 2,060member
    Some browsers *cough*OmniWeb*cough* have problems with these kinds of things. If you get to playing with it, it stops working sometimes (i.e. you select a menu item but the page wont automatically load.)



    I'll be happy if they keep the button but have it redirect automatically.



    In any event, I use a folder full of bookmarks to navigate AI from my OmniWeb toolbar, so I suppose this issue doesn't affect me much...



    [ 12-30-2002: Message edited by: Spart ]</p>
  • Reply 4 of 5
    murbotmurbot Posts: 5,261member
    [quote]Originally posted by Defiant:

    <strong>exactly. what if you select the wrong one ?</strong><hr></blockquote>



    This happens at the MacNN forums, and I think it's a pain. I've selected the wrong forum a few times, then have to wait for the page to load, and then do it again.



    I don't think there's anything wrong with having a Go button to click.
  • Reply 5 of 5
    ibrowseibrowse Posts: 1,749member
    And to save a click or two, the forums are also linked at the very bottom of every page.
Sign In or Register to comment.