Using CVS in Mac OS X

Posted:
in Genius Bar edited January 2014
I'm having trouble using CVS with Apple's open source servers. I'm following the instructions at http://developer.apple.com/darwin/to...ead-only.html/.



First step: set the CVSROOT variable:

%setenv CVSROOT server:batstoo@anoncvs.opensource.apple.com:/Users/stoo/programs/cvs




Success: environment variable is

server:batstoo@anoncvs.opensource.apple.com:/Users/stoo/programs/cvs



Next:

% cvs login

(Logging in to batstoo@anoncvs.opensource.apple.com)

CVS password:

/Users/stoo/programs/cvs: no such repository

cvs [login aborted]: authorization failed: server anoncvs.opensource.apple.com rejected access





Any idea what the problem is?

Comments

  • Reply 1 of 2
    thuh freakthuh freak Posts: 2,664member
    the problem is with that environment variable. it should be:

    Code:


    server:batstoo@anoncvs.opensource.apple.com:/cvs/Darwin







    the path (after the last colon) is a path on the server, and ur not supposed to replace it with something local.
  • Reply 2 of 2
    stoostoo Posts: 1,490member
    I've replaced the path with /cvs/Darwin (as shown on the Apple guidelines) and still get the same error.
Sign In or Register to comment.