Using Perl on Earthlink (talking about MODULES)

in Mac Software edited January 2014
Hey, this is about Perl.....

My domain is hosted by Earthlink and I'm having trouble getting some Perl scripts to run because they don't have all the necessary modules installed. Are any of you guys good with Perl?

Can I just make a directory inside of my root folder to put new modules or does it have to reside inside a directory inside of the cgi-bin?

I was trying to get Blosxom beta2 rc2 to work, to no avail. Somebody suggested that my was whacked, which it was. I installed a new version (2.88) of inside a new directory in my cgi-bin and suddenly the beta2 of Blosxom started working...except for the plugins. I expect that they're looking for a Perl module that's been left out of the installation on the Earthlink of their reps emailed me saying that they didn't have a lot of modules installed.

Not expecting anybody here to know what the HECK I'm talking about. Two weeks ago I wouldn't have known what I was talking about!


  • Reply 1 of 6
    shetlineshetline Posts: 4,695member

    Originally posted by drewprops

    Not expecting anybody here to know what the HECK I'm talking about. Two weeks ago I wouldn't have known what I was talking about!

    I was starting to struggle with this issue once before myself, but I upgraded my web hosting service before I really had to buckle down and solve the problem -- and suddenly the stuff I wanted was already installed, plus I was able to do PHP as well and didn't need Perl as much (A combination of Perl CGIs and Apache server-side includes is a poor substitute for PHP, that's for sure!)

    I'd be curious, however, to get an answer too because I was certainly scratching my head before intervening events saved the day. I'm still using an old home-made hack to send e-mail because even the new hosting plan doesn't have any of the Mail modules installed.
  • Reply 2 of 6
    drewpropsdrewprops Posts: 2,321member really SUCKS that they can't run the latest-greatest full-on installation of perl. The biggest question is where do I install the requisite modules?
  • Reply 3 of 6
    I was mucking about with the TikiText plug-in for MT/Blosxom etc. on my Mac and when I first tried to call it from the command line I had the .pm (Perl Module) in the wrong place.

    The error message gave me the list of locations it had tried, but it was fairly Mac/Fink specific (e.g. Library/Perl/), if you've got command line access you could try running something that calls the module and seeing what the error says.
  • Reply 4 of 6
    drewpropsdrewprops Posts: 2,321member
    You can't Telnet into Earthlink's servers, they don't allow it. There -is- a 'perl debugger' you can run from their web-based control panel, it'll check any scripts you have in the cgi-bin directory.....not sure if my 'plugins' directory needs to be sitting in my root directory or inside my cgi-bin directory...doing experiments as time permits.

    Do all of the .pm's required by these plugins belong in the cgi-bin directory or inside the plugin directory? That might be an important question.

    Rael's Yahoo-based discussion board is CRAP to navigate...but it's free.
  • Reply 5 of 6
    disclaimer: not a Perl hacker.

    If you got the the to work then you want to put the other .pm's in the same place except inside apropriate directories. My .pm had to go inside Text, so I had to create a folder called /Library/Perl/Text and place it inside that, rather than just /Library/Perl.

    I think the location is reflected in the name (i.e. Text::Tiki) so follow that scheme.

    So if CGI is in /whatever/ then put anything called Text::Something into /whatever/Text/ and so on... - watch out, the case is probably important!
  • Reply 6 of 6
    drewpropsdrewprops Posts: 2,321member
    Caveat Emptor, I'll sprinkle some salt on your suggestions and release you from indemnity SLF...

    I have got to try this out when I get an opportunity. By the by, which plugin do you think is the easiest to install? In otherwords, what plugin works right out of the box by simply dropping it into the plugins directory? I found one called TEST that works, but all it does it print some text to the screen that says that it works. I want to see a plugin DO something!

    Picky ain't I?
Sign In or Register to comment.