Powerbook Ti, WinXP, AIrport, Home network

in Current Mac Hardware edited January 2014
I have the following setup:

- Dell desktop with WinXP

- Apple Powerbook Ti

- Airport Extreme

- Linksys router

- Cable modem

My cable modem is connected to the router and my airport is connected to my router.

If I turn on the Dell after turning on the Powerbook I can't get an IP address.

Sometimes my powerbook picks up the wrong IP address.

Is there a way I can set this stuff up so that no matter what I turn on i'll get the right IP addresses?


  • Reply 1 of 8
    alcimedesalcimedes Posts: 5,486member
    you could just set up your PB to grab a specific IP, not using DHCP (for the IP address only)
  • Reply 2 of 8
    Depending on what Basestation you have, you probrably can get rid of the router.

    My home network looks like this:

    Phonejack>DSL Modem>Airport Basestation>PC.

    I'm able to run the pc and my TIbook at the same time on the internet with no problems.

    The basestation acts as a router. I just plugged my PC into the LAN port on the basestation. I set it up by running IPCONFIG on the PC to assign IP an IP adress to the pc and I ran the Airport setup utility on the TIbook to set up its connection. It wasn't a simple task to set up. In fact, I had a network administrator on the phone telling me what to do. You might have to get some similar help.

    Also I am using an older basestation. (802:11B) The Airport Extreme uses 802:11G. I don't know that it makes any difference but it is a different protocol.

    Good luck.
  • Reply 3 of 8
    serranoserrano Posts: 1,806member
    A friend of mine had the same problem, his sisters powerbook was stealing ip addresses. His setup was almost identical to yours. His solution was to disable DHCP and assign IP's to each comp.
  • Reply 4 of 8
    klinuxklinux Posts: 453member
    The ideas that alcimedes and serrano described are work arounds as opposed to actually fixing the problem i.e. why aren't you getting the correct address via DHCP.

    As other had suggested, if you are using only one PC and a powerbook, then you probably do not need the Linksys router. While I am not familiar with airport (I have a linksys wireless router and a few PCs + iBook), you shoud be able to use DHCP and use a modem-airport-dell and wireless to Powerbook setup.
  • Reply 5 of 8
    jeagenjeagen Posts: 31member
    The issue may also be that both your airport and linksys are setup for DHCP, which will cause problems.
  • Reply 6 of 8
    musicaltonemusicaltone Posts: 189member
    YOu dont need the rounter. Just plug the WinXp desktop into the AE base stations ethernet socket and network the PB wirelessly using Airport. Use DHCP for both. I found these links usefull:


  • Reply 7 of 8
    moliumoliu Posts: 42member
    I haven't had any problems with airport winxp...

    My current set up is

    DSL modem --> router/hub --> airport(with dhcp turned off). Works fine with me. The router does the dhcp and it seems to work perfectly. Everything is on auto detect ip... I have multiple winxp running... no problem at all...
  • Reply 8 of 8
    1337_5l4xx0r1337_5l4xx0r Posts: 1,558member
    Why do you two have routers? Any wireless access point you buy these days is a router/firewall/print server/wifi base station.

    Sell the router. It's not doing anything (useful).
Sign In or Register to comment.