Why must I unplug/plug-in my mouse all the time???

in macOS edited January 2014
I have a USB hub that all my USB devices are attached to at work (I have a PB). When I get to work, I plug my USB hub into my PB (after I "wake it up" of course), and it never fails, my damn mouse doesn't respond! Only after I unplug the mouse from the hub and plug it back it does it work--sometimes my PowerMate behaves the same. Of course the keyboard always works.

I've tried this with and without the power-adapter for the hub.

Is this an OS X issue, or something else?


  • Reply 1 of 6
    chuckerchucker Posts: 5,089member
    Sounds like a buggy hub to me.

    Try running http://www.grantedsw.com/usb-monitor/ (works in background) and plugging your USB hub out and back in for multiple times. See if it's recognized by your OS every time. If it isn't, you've got the same problem I do
  • Reply 2 of 6
    ebbyebby Posts: 3,110member
    Funny, my Logitec mouse does kind of the same thing. When ever I boot up, my computer detects a mouse, but dosn't know what kind or the preset buttons I programeed until I re-plug it. I think mine is a software problem though and I never got around to fixing it yet.
  • Reply 3 of 6
    skyboltskybolt Posts: 111member
    I upgraded to a USB 2.0 hub and all such problems have resolved. The regular hubs (powered or unpowered) just don't seem to have the mbps needed. USB 2.0 is backward compatible with USB 1, so no problems there. Good luck.
  • Reply 4 of 6
    fuzz_ballfuzz_ball Posts: 390member
    I loaded the USB software you mentioned and tried unplugging/plugging my my hub several times and it reported everything correctly, and of course everything is working. Hmmm, the test will be Monday I guess when I come into the office and hook everything up for the first time.
  • Reply 5 of 6
    fuzz_ballfuzz_ball Posts: 390member
    Okay, installed that software and when I plugged in my hub this morning, I saw the list of "USB devices" pop up, and noticed that my mouse did not appear. So I unplugged the hub, and then plugged it back in. Same problem. So I unplugged the mouse from the hub (the app didn't *notice* this action) and then plugged my mouse back into the hub, at that point the USB app *saw* my mouse and reported it, and of course, my mouse actually worked.

    So I guess the problem is my hub???
  • Reply 6 of 6
    ti fighterti fighter Posts: 863member
    i have this problem with my logictech wireless mx mouse (and have had it with other wireless logictech mice). I never turn my computer off, but when it goes to sleep over night and then i wake it up, i have to unplug, in this case the base station/charger, and plug it back in. Its not a big deal since i have it going into the keyboard but weird none the less. I think though if i have the mouse in the first usb port on the back of the tower it fixes the problem but it wont reach right now in my current set up.
Sign In or Register to comment.