TiBook battery showing signs of "memory effect"... whuh?

in Genius Bar edited January 2014
I know lithium-ion batteries should theoretically not be susceptible to the memory effect, but it looks like it's 'forgotten' that fact to me...

When I first got my DVI TiBook, the battery capacity was a healthy 2:40 hours or thereabouts. Now, at full charge, the Finder menulet estimates that it holds a whopping 45 minutes. This isn't a matter of my having changed any Energy Saver preferences vis a vis performance setting - I've kept them the same since the beginning, apart from occasionally setting the computer's sleep times.

The little dialog box warning that used to come up whenever I ran "into the red" on the battery meter never appears anymore, and oddly enough when I get down to a reading of 0:02 or 0:01 minutes the meter freezes there for up to half an hour or more, with the computer running along perfectly happily and me wondering when exactly it'll realize it's running on fumes.

I calibrated the battery by charging fully and discharging fully when I first got the machine, and have tried doing that repeatedly since, to no effect. I've reset the Power Manager by pressing the little button on the logic board and that hasn't done anything either.

Is this a common thing? Do I have to drop AUD$250 on a new battery?

I got the machine in America and am now in Australia, so I don't know if I'm still covered by the warranty - which must only have a few weeks left to run, too, since I got this just after Macworld NY '02.

Also - ever since I got back to Australia, I've noted with some concern that whenever it's plugged into the Power Adapter, the case of the TiBook actually becomes slightly electrified. There is a really (really!) noticeable tingle whenever you touch it, which is hell if I rest it on my lap.

Been having no end of problem with dodgy Apple products recently... thankfully I was born into the cult and my faith is unshakable like unto that of the heroes of old.

Any help would be greatly appreciated!


  • Reply 1 of 7
    ebbyebby Posts: 3,110member

    Originally posted by Shalmaneser

    which is hell if I rest it on my lap.

    Just wondering, but is the power the same Down Under as it is in America? (120V 60Hz) I've never had a static electricity/grounding problem on a laptop before. Which is really bad for computers, but you probably know that.

    <thinking out loud>

    I wonder if the static electricity could be messing up the battery voltage sensor somehow?

    </thinking out loud>
  • Reply 2 of 7

    Originally posted by Ebby

    Just wondering, but is the power the same Down Under as it is in America? (120V 60Hz)

    Ah, no it isn't. That's the only thing it could possibly be, but my grasp of why it's happening is fuzzy (my electrical engineering knowledge is pitiful!) Australian power is 240V at 50Hz. I was going to go buy a new adapter at first till the guys at the Apple Store here told me the TiBook power brick was auto-switching, and sure enough when I checked, its input rating is 100-240V, 50-60Hz, 91-124VA.

    However the lead I bought that adapts the power brick to the wall socket is a cheap, non-Apple-issue Chinatown deal, could that have something to do with it, you think?


    <thinking out loud>

    I wonder if the static electricity could be messing up the battery voltage sensor somehow?

    </thinking out loud>

    I was wondering about that too. Now that I think about it I can't remember when I noticed the dropoff in battery power, whether it was before or after the move.

    This isn't static electricity though - there's actual current flowing through the case! It must be bad for the computer somehow, but I haven't yet lost any data (touch wood) or noticed anything catastrophic... it's just prickly!
  • Reply 3 of 7
    ebbyebby Posts: 3,110member
    It could also be that some of the cells inside the battery died. Does the battery get unusually hot during charges? Or does it charge all-the-time? If some of the cells are dead, the only thing to do is replace them. But it still doesn't explain the weird current.

    EDIT: Hope you don't have the same kind of battery I do (contacts are closely shielded) or else you can't test the battery and everything I just typed won't matter.

    If you have testing equipment (multimeter) you can see how many volts the battery has fully charged and compare that to what the label says it should have. If it is off more than 1.5 volts (after fully charging it) than you have a dead battery.
  • Reply 4 of 7
    baumanbauman Posts: 1,248member

    Originally posted by Ebby

    <thinking out loud>

    I wonder if the static electricity could be messing up the battery voltage sensor somehow?

    </thinking out loud>

    No, the battery gauge is based on the voltage that is put out, and the extra EMI would have absolutely no bearing on that.

    As far as any solutions go... I'm at a loss.
  • Reply 5 of 7
    paulpaul Posts: 5,278member
    the current on the case deal happen(ed) to me as well, since then I had to send the computer into apple twice for two different reasons unrelated to the current... i haven't gotten it back yet, but when i do i'll check if it is still there...
  • Reply 6 of 7
    der kopfder kopf Posts: 2,275member
    There is a way to reset the power manager though, no? I'm skeptical as to its possible success, seeing the static electricity problem, but you never know. Could someone freshen up this knowledge? Where is the Genius Bar samaritan?

    Another 2 cents: seems all new Apple acdc adapters are autoswitching these days, I had no problems plugging in my European bought iPod in American power outlets. I love that.
  • Reply 7 of 7
    kraig911kraig911 Posts: 912member
    Borrow a battery from someone else, and stick it in and see if it reads the same way, it could possibly be something got corrupt in the OS.
Sign In or Register to comment.