file refuses to delete...

in Genius Bar edited January 2014
even after trying sudo rm -fd from the terminal...

the stubborn folder with a folder and 4 files in that folder refuses to be deleted...

I also tried to delete the file from cocktail with no luck... anyone seen this before?


  • Reply 1 of 9
    alcimedesalcimedes Posts: 5,486member
    use the "root" luke.

    but only if you're careful and know what you're doing.
  • Reply 2 of 9
    paulpaul Posts: 5,278member
    is there a safer way to do it like maybe starting up in target disk mode and deleting from another mac? i'll try that tomorrow...
  • Reply 3 of 9
    costiquecostique Posts: 1,084member
    sudo rm -rf thestubbornpornfoldername.

    Warning: first make sure you are in its parent directory (typing ls should show the problem folder name). Second, type the folder name correctly without errors, tabbing for autocompletion. Remember that if you type the wrong folder name, you won't be able to undo it.
  • Reply 4 of 9
    paulpaul Posts: 5,278member
    well i tried everything on this page and i still cant get it to go away... I'll post pics later...

    the files have some weird characters in them and it refuses to let me edit them for any reason...
  • Reply 5 of 9
    sebseb Posts: 676member
    Try starting up from an OS 9 CD and deleting it. Or booting into OS 9 if you have it on your Mac.
  • Reply 6 of 9
    There is a program called Cocktail which will delete any file, no hassel, even empties the trash if you can't empty with finder. Very usefull tool. Does more than that too. You can get a new lease from your DCP Server. turn on journling etc... I think you can find it at
  • Reply 7 of 9
    paulpaul Posts: 5,278member

    Originally posted by seb

    Try starting up from an OS 9 CD and deleting it. Or booting into OS 9 if you have it on your Mac.

    seb, i'll just ask at the GB at SoHo on sunday... what time do you think I should get there to get a parking space on the street?

    btw, Altivec, if you read my original post you would see that cocktail didn't work...
  • Reply 8 of 9
    paulpaul Posts: 5,278member
    well, i went to the GB... and after like 2 hours... os 9 did the trick
  • Reply 9 of 9
    ast3r3xast3r3x Posts: 5,012member
    man OS 9 still is saving people

    still a major problem with OS X is stubborn privs...although i've been lucky and they have all worked very well for me
Sign In or Register to comment.