Big Problems with Airport Extreme, please help!

Posted:
in Genius Bar edited January 2014
I switched to a Airport Extreme base Station from a regular non extreme base station (the latest non extreme ). I have an iMac and two PC's connected wirelessly through the Airport.



Before I had no problems at all connecting my two PC's to my network, now I'm racking my brain on why I can't seem to connect them.



When I click on my wireless connection in Windows XP it shows my networks name, it then asks me to type in the network password and click connect.

It accepts the password, but when I click connect absolutely nothing happens, only the iMac seems to find the Airport Extreme base station, the PC's are even closer to the base station than the iMac.



Everything's in the same place as before so didtance cannot be a factor.



Does anyone have any idea on what's going wrong?



And while I'm asking, can you print wirelessly with the Airport Extreme base Station to Windows XP?



The reason I switched is I wanted to be able to print wirelessly to my USB printer. I got it working with the iMac but will it work in Windows XP also.



I appreciate all help.

Comments

  • Reply 1 of 2
    regreg Posts: 832member
    We have the extreme base station and everything connects, macs 9.2 and 10.2.6, win 2000 and XP. We don't have it password protected..no need where we are. Only machines running 10.2.3 and above can print using the hub usb printer.



    reg
  • Reply 2 of 2
    1337_5l4xx0r1337_5l4xx0r Posts: 1,558member
    Try turning off passwords and turn on MAC address filtering. I have no idea how to do this on an ABS.
Sign In or Register to comment.