Multi-homing - not on my new powerbook?

Posted:
in macOS edited January 2014
I read that OSX is supposed to be multi-homing, so it can detect and use the best networking method automatically. I have configured my ethernet network to my work network and I've also configured the modem for when I'm at home.



As far as I understood, the powerbook would be able to detect whether the ethernet cable was attached and, if not, use the modem. Have I misunderstood this or is mine not working correctly for some reason?



I plugged in to the company network this morning but every time I tried to do anything it tried to dial up (and obviously ailed). It wasn't until I deactivated the modem config that I was bale to use the network through the ethernet connection.



Have I completely misunderstood the concept or have I missed soem config or soemthing. Location is currently set t Automatic.



Any help greatly appreciarted.

Comments

  • Reply 1 of 3
    wiftywifty Posts: 70member
    This is where I read it:



    From: http://www.apple.com/powerbook/wireless.html



    Automatic networking:

    the power of Mac OS X AirPort Extreme represents the hardware side of the wireless networking equation. On the software side, the PowerBook G4 benefits from the Mac OS X networking architecture. Mac OS X is a multihoming operating system, which means that it can use all of its network interfaces at the same time. When you first set up your PowerBook G4, each network interface is automatically configured. So at work you may use the built-in Ethernet interface to connect to your local area network. When you go home, you may connect to the Internet wirelessly via AirPort Extreme. Because each of the network interfaces is already configured and because Mac OS X can use all of its network interfaces at the same time, Mac OS X will automatically see that you are no longer connected to the Ethernet network and instead begin using your AirPort Extreme connection. And if you go on the road and use the built-in modem to dial up to the Internet, Mac OS X will automatically use the modem to create your Internet connection. You don?t have to change any settings or locations.



    Anyone else having this problem?
  • Reply 2 of 3
    smirclesmircle Posts: 1,035member
    Quote:

    Originally posted by Wifty



    Have I completely misunderstood the concept or have I missed soem config or soemthing. Location is currently set t Automatic.




    I had a similar problem back in the 10.1 days, so this might no longer be applicable, but I solved it back then by rearranging the network ports in "Network Port Configurations" (the last item in the "Show" popup. Putting Airport and Built-in Ethernet before Internal Modem did the trick.
  • Reply 3 of 3
    airslufairsluf Posts: 1,861member
    Kickaha and Amorph couldn't moderate themselves out of a paper bag. Abdicate responsibility and succumb to idiocy. Two years of letting a member make personal attacks against others, then stepping aside when someone won't put up with it. Not only that but go ahead and shut down my posting priviledges but not the one making the attacks. Not even the common decency to abide by their warning (afer three days of absorbing personal attacks with no mods in sight), just shut my posting down and then say it might happen later if a certian line is crossed. Bullshit flag is flying, I won't abide by lying and coddling of liars who go off-site, create accounts differing in a single letter from my handle with the express purpose to decieve and then claim here that I did it. Everyone be warned, kim kap sol is a lying, deceitful poster.



    Now I guess they should have banned me rather than just shut off posting priviledges, because kickaha and Amorph definitely aren't going to like being called to task when they thought they had it all ignored *cough* *cough* I mean under control. Just a couple o' tools.



    Don't worry, as soon as my work resetting my posts is done I'll disappear forever.
Sign In or Register to comment.