Rendezvous & DHCP Windows Server?

in macOS edited January 2014
This is driving me mad - first of all can someone give me a straight answer. Should Rendezvous work with a Windows Wireless DHCP server?

Here's a few more details on my set up.

I've got a Windows server (running Windows 2000 Advanced Server) up in my loft with a Linksys Wireless (802.11b) basestation. I've got the server set up so that it's distributing IP's via DHCP. My DSL connection is connected to this server and shares it to machines connected to the Wireless network.

I've then got two PC's that connect via WIFI and then my two Mac's (both with AP Extreme). All of the machines have IP's from the DHCP server - all on the same subnet.

After getting my PowerBook I thought it would be cool to try out rendezvous by sharing my Music collection from my eMac to my PowerBook - so I enabled all the sharing options on iTunes for both the PowerBook and eMac and to my disappointment - no music was being shared I waited hoping it was just taking a while - but nothing.

So i tried rendezvous iChat (with the AV beta) - again no luck. They just didn't find each other - although being connected to the same network.

So, I created a "Computer to Computer" network using Airport Extreme between the two Mac's and it all started working. The things you can do with Rendezvous when it works are ace - it rocks. Thing is, I need to have it working with my Windows server, otherwise - when using the "Computer to Computer" network - I can't connect to the 'net via my server in the loft as the IP's are given automatically - and aren't on the same subnet as my server...

Surely someone has been in this situation? Did you find a way of solving it?

Really would appreciate anyone's help in getting Rendezvous working with my set up - if not, are there any suggestions you can make to how I can get it working?

Thanks in advance


  • Reply 1 of 9
    technically, i can't think of anything the windows server should do to allow rendezvous, aside from not blocking it. you may want to check the firewall settings on the router and server to make sure they aren't blocking rendezvous (i can't remember what port(s) its on). If you have a firewall on, then that may be blocking out rendezvous. Also, for iTunes (v4.01 and up), both computers need to be on the same subnet (which they probably are, when they use the wireless network, but you may want to check that, if u get iChat to work and not iTunes).
  • Reply 2 of 9
    dfilerdfiler Posts: 3,420member
    If I understand correctly, your windows box is acting as a software based router. This is where you'll need to make changes to the configuration. I don't think dhcp should have any bearing on rendevous.

    If you were running NAT on a linux or OS X box... i could be of help. (don't know squat about how this is done in win2000)
  • Reply 3 of 9
    All the server is doing is sharing the Internet and hosting the Linsys Wireless Access Point as well as giving out the IP's via DHCP.
  • Reply 4 of 9
    voxappsvoxapps Posts: 236member
    Port 3689 needs to be open for iTunes sharing. If your computers are all running firewalls, make sure 3689 is open. This applies to Macs as well if they're using OS X's firewall.
  • Reply 5 of 9
    Also, check your Linksys WAP...Some models (including mine) have an issue supporting 802.11g cards (like the Airport Extreme cards)...

    My Powerbook will connect, but at a frighteningly slow pace unless I throttle the Linksys down to 1-2Mbps.
  • Reply 6 of 9
    When you set up your w2k box, did you run the AD wizard? Are you running a domain that ends in .local? This is the suggested setting in the AD wizard, and it fcuks everything up for mDNS (Rendezvous) clients. See, .local is what mDNS uses when assigning hostnames in the absence of local DNS - so everything goes very strange. Also, you could sniff your mac clients - using sudo tcpdump in the Terminal, and check that mDNS multicasts are occurring on port 5353.
  • Reply 7 of 9
    stoostoo Posts: 1,490member
    Look for an option for UPnP on your Linksys router's setup application (Most routers like this host small, local webpage interfaces) and turn it on. Universal Plug and Play is what the rest of the world calls Rendezvous (nothing to do with Plug and P[lr]ay of Windows notoriety).
  • Reply 8 of 9
    I can't find the UPNP option anywhere on the Setup.

    I've got a Linksys WAP11 ver2.2
  • Reply 9 of 9
    ok - it now works after updating the Firmware to Version 1.1


    A note on updating the firmware... you'll need to unplug the WAP and then plug it back in in order to restart it for the Firmware Update to take effect.
Sign In or Register to comment.