huge performance problems in Panther

in Genius Bar edited January 2014
After blissfully using Panther for about a week, my system in the last 2 days has come to a total crawl. For example, if I move the mouse down the the dock, it beachballs and takes literally 20-30 seconds for the icon label to pop up. All my clicks are very delayed, applications take literally minutes to launch, windows do not drag, and the beachball shows up quite bit, seemingly too busy with something in the background. It's incredibly slow to start just the Finder on bootup. I can let the computer sit idle, pull up the activity monitor and listen to the hard drive just spin off and on without ever resting. I can leave it sitting idle for 10 minutes and the HD continues to thrash.

Here's what I've tried so far:

? restarting,

? shutting down, letting the iMac sit and restarting it,

? removing everything from my login items, changed from auto-login to the login window on startup,

? removed all peripherals and plugged in my Apple mouse again

? checked my RAM, my hardware profile, etc.,

? checked the Activity monitor which, when I'm able to view it or it itself isn't hung, reports normal to high use of the Finder, the Dock, the windowserver and of course the Activity Monitor,

? checked my other account on this system for any problems in it (same problem, no apparent fixes)

? deleted my Dock, Finder, System Prefs plists and any other pertinent prefs both from my home folder and from the main Library folder

? deleted all caches in all accounts and library folders

? removed all menulings including the clock from the menubar

? changed my iDisk synching to manual, removed everything from my Finder's sidebar, went to the default preferences for the finder and Dock, etc.

? reset my Airport and my computer's network settings

? ran MacJanitor

? ran "fsck -y -f" on my journaled volume on single-user startup

? "reset-all" from Open firmware on startup

? ran Disk Utility from the Panther CD, repaired permissions

I'm out of ideas. I have about 12 GB out of 40 left, I just installed SketchUp 3, though deleting it didn't make a difference, and it didn't seem to be a problem anyway. Otherwise, normal use when this just happenned.

Have I missed anything? I hate to do a reinstall, and given everything else I've done, I'm not sure what good it's going to do. Thanks for any input?


  • Reply 1 of 4
    chychchych Posts: 860member
    Did you archive/clean install initially? When I upgraded my 10.2, I was plagued with issues like this, so I reinstalled via archive/install/import users and most of them are solved.
  • Reply 2 of 4
    buonrottobuonrotto Posts: 6,368member
    I did an archive and install. My problem seems intermittent. One thing I didn't make clear is that my other users aren't necessarily logged in when I have the problems. I suspect that it's a combination of a few things, but I'm trying to weed out a few suspects right now. I noticed ICeCoffEE was all over the console logs, so I've removed it temporarily. I noticed that on one startup, before I turned off automatic synching, I was having problems connecting to my iDisk in the first place. I've noticed that the System Preferences app seems to be slow loading and responding for some reason, might be because of any number of reasons. I wonder if some personal files have the wrong permissions even now, that they haven't updated to my new account and are locked or looking for an unknown user. Finally, I have been doing work with 3D and a ton of image files recently, and wondered if I somehow missed a cache that was filling up and hogging RAM and swapping out like crazy. My activity monitor doesn't suggest it specifically, but it's not easy to see what's going on when this problem is happening. I've only deleted caches that I can see in my regular admin account, nothing in hidden folders, so maybe I'll see if there's something more thorough. Finally, I'm a little worried that maybe it's something I don't understand about Exposé and/or the Dock that's a cause.

    Right now, I'm fine after laving my machine logged in all day but sleeping most of the time.

    I have to create a more systematic way of isolating and testing any of these things, and maybe a few more.
  • Reply 3 of 4
    buonrottobuonrotto Posts: 6,368member
    You know what, forget all that. I'm almost positive it's the Finder plain and simple that's the culprit. I went through a bunch of apps, file and settings just now, but I didn't have any problems until I went back to click on an open Finder window. Then everything hung. I wasn't even looking at a large folder of stuff. I'm going to see whether I've properly disposed of any caches the Finder accesses, its preferences, etc.
  • Reply 4 of 4
    Launch top from the terminal.
Sign In or Register to comment.