Panther won't install on 1.33 Ghz PowerBook 17" !!

in Genius Bar edited January 2014
I have had it. I've repaired permissions, I've ran TechTool, wiped the hard drive clean, customized the install, tried "Erase and install," erased it, then tried "Install Mac OS X for the first time," zeroed all the data, etc..

EVERY time, the installer quits, or the screen turns grey, or blue, or I get a kernel panic during installation.

So, I've tried taking RAM out, first the 512M that came with it, then the additional 512MB. I've switched the chips around. Even resetted the PRAM, and the Power Manager.

My conclusion is that both RAM chips are bad. Any other ideas?

By the way, 10.2.7 installs, and runs like a dream, with no problems. Pretty quickly too - this machine is waay fast. In Jaguar, that is.


  • Reply 1 of 3
    Possibly you have a bad Panther CD? Call Apple or visit an Apple store and discuss this idea with them.

    If possible, borrow a Panther disk and try that. If the borrowed disks work that proves you have a corrupt set which Apple should replace.
  • Reply 2 of 3

    Fixed it. Went to the Soho Apple Store, and they yanked all the RAM, and put in their own. Installed just fine. Funny, the dude next to me, had the exact same problem with his PB 1.25 Superdrive. Seems like Panther is waaaay pickier about RAM than Jaguar ever was.
  • Reply 3 of 3
    regreg Posts: 832member
    Panther would not install on my wife's pb 17 1.33. Wiped the drive and tried a clean install. Nothing worked. Sent it back in. Apple replaced the logic board. It was back in the house in less than 4 days from when it was sent out. Everything works great now. Big change from her Ti 500.

Sign In or Register to comment.