Bit of a weird iBook situation here...

in Genius Bar edited January 2014
The short version:

CANNOT get the keyboard to pop up to install's held down by a little locking screw located between the F5 and F6 keys. This little "locking screw" will simply not give up its hold!


For detailed background/specifics:

Stopped by my friend's house last night to drop a 512MB into her new 14" iBook G4. I've done this on no fewer than 5 occasions, both with current iBooks and the older "toilet seat" models. In other words, it's old hat for me. I expected a usual 10-minute procedure.

So I shut down, unplug everything, flip it over and remove the battery, open it back up and slide the little tabs next to the Escape and F12 keys to unlock/flip open the keyboard (we just did this exact thing 2 weeks ago when we installed her AirPort Extreme Card).

Anyway, keyboard would NOT flip open. I noticed in the manual it says if this happens, keyboard may be locked and to turn this tiny little screw (located between the F5 and F6 keys) a "half turn" to unlock the keyboard.

This didn't work AT ALL. Little screw (appears to be plastic, no less) just keeps spinning. I didn't force anything and I didn't "manhandle" it. I simply stuck one of those tiny flathead screwdrivers in there and gave it a gentle turn, expecting it to unlock.

I finally called Apple tech support and apparently it's Trainee Week 2003 there...this guy didn't seem to be aware that a G4 iBook even existed, much less know ANYTHING about this keyboard lock thing. After 5 minutes of one word answers and hearing him type and flip through pages, I demanded to be transferred to someone "a bit more iBook savvy", but he kept going on about "we've done all I know to do..." (which consisted of - sit down - "turning the screw a half turn"). Well no shit, pal. I'm CALLING YOU because that doesn't appear to be working!!! But THAT'S a whole other thread...

Called the Atlanta Store to talk to a "Genius". No Genius to be found. In fact, no one even picked up the phone after 22 rings. Must be busy at the Lenox Mall store.

So I have a call in to the local (and sole) Apple authorized service center here in town, waiting to hear back from their service tech. Hopefully sometime this month.

In the meantime, have any of you encountered this? Have a workaround/fix for it? The useless guy at Apple said "they come unlocked from the factory", which I know: we easily popped the keyboard off 2 weeks ago to do the AirPort thing. My friend hasn't messed with it. She was like me: she had no idea there was even a screw/locking mechanism there (it's tiny!). She's not the type to go messing around like that anyway.

So here we are with a brand new 512MB DIMM and can't get the damn keyboard off to INSTALL it!

Suggestions? Inside scoop? Special insight? A workaround? Alternate ideas? Dynamite? Anything?



  • Reply 1 of 8
    half turning it while putting some pressure on the lock at self (pressing down?) Also on mine I have to like push down with the other hand too so the little latch thing comes out. My powerbook sometimes jams up too.

    You could try hitting it with a big heavy hammer.
  • Reply 2 of 8
    cj3209cj3209 Posts: 158member

    Originally posted by kraig911

    half turning it while putting some pressure on the lock at self (pressing down?) Also on mine I have to like push down with the other hand too so the little latch thing comes out. My powerbook sometimes jams up too.

    You could try hitting it with a big heavy hammer.

    Keep turning it counter-clockwise for a bit, then turn it a half turn to see if the keyboard comes up. If not, turn the screw another half turn and see what happens.

  • Reply 3 of 8
    pscatespscates Posts: 5,847member
    Sure you don't work for Apple tech support? Sounds about like the guy I talked to last night

    I tried that.

    I don't know if you're being serious or a smart-ass. But I'll give you the benefit of the doubt...

  • Reply 4 of 8
    alcimedesalcimedes Posts: 5,486member
    just get a precise sized drill bit.....

    well, i suppose that's not the best solution. nah, i think kraig has it right. (press down HARD)

    or try and get the flat edge under the lip of the screw, see if it comes out. i have yet to ever work on a G4 iBook, so it's a bit up in the air.
  • Reply 5 of 8
    der kopfder kopf Posts: 2,275member
    You might try to push in the little lip of the lock while turning the screw. I just checked this thing (although... I realise just now I'm back on my olde G3 ibook for now) and the lock is just a minute petite slab-square thing of plastic that sticks out straight forward (towards the screen, in other words). So maybe (maybe, I confess that I see the attempt doomed before it's even laid out) you could pin something very sharp and thin (thin enough to fit in the very tight crevasse between keyboard and casing, obviously) in the plastic, pierce it just a bit, and try to push it into the keyboard, while turning the screw.

    Just a thought.
  • Reply 6 of 8
    alcimedesalcimedes Posts: 5,486member

    from apple's own tech documents.
  • Reply 7 of 8
    Have you reseated the keyboard since you got it? I mean, have you opened it up and put it back? My first iBook, I reseated the keyboard incorrectly (off to the side a bit) and I COULD NOT get it back up. I thought it was the little lock thingy, but I had to get a little swiss army knife blade and slide the keyboard to the other side a bit before it would come up. Can you try that? Try to get it centered then open it. Good luck, man.
  • Reply 8 of 8
    pscatespscates Posts: 5,847member
    Good news, good news! Problem solved, situation fixed. RAM is in, all is well.


    After talking with the local service tech guy - and actually der Kopf's thread - I knew more what to look for...I got the little thing to turn and put a lamp directly above to see "down into" the keyboard area and where it meets the body and see this little piece clear the "lip". Once I got THAT loose, however, the LEFT side was hung a bit, due to - as mentioned above - a possible "re-seating" thing from our AirPort Extreme card installation two weeks ago? Anyway, emboldened by my success with the little bastard screw/lock thingy, I jiggled that for a few minutes and the keyboard FINALLY released. Proceeded to remove the AirPort Card, RAM shield, installed the 512MB DIMM, replaced shield, replaced AirPort card, inserted battery, booted up, smiled at another job well done, etc.

    Reading 640MB in both places (About This Mac and System Profiler). AirPort works perfectly as before. All looks A-OK.

    All is well, situation under control! Friend is happy, I'm happy, etc.

    Mods, close thread at longer needed.

Sign In or Register to comment.