1ghz TiMac stuck CD-R

in Genius Bar edited January 2014
I was burning a Christmas CD last evening and when I put in the blank cd that iTunes was asking it got stuck. It went in far enough to be totally enclosed in the drive, but not far enough to spin or be read by the computer. I have tried F12, restarting and holding down the trackpad button (when the computer starts up it is really trying hard to get rid of the cd - it tries about 10 times before it just goes on with the regular startup), resetting pram, resetting power manager (off of the support section of Apple). I even tried to grab the cd out of the slot (I can see it in there). No luck with any of these methods. Any ideas?


  • Reply 1 of 2
    Here's a few more things to try. If they don't work, it's time to take it in.

    1. Have you tried jamming it in even further? Maybe to get it to register?

    2. Try restarting the computer, hold down the Option key, and use the startup manager to open the tray.

    3. During startup, press and hold the Command-Option-O-F key combination to enter Open Firmware, type "eject cd" in lower case letters, then press return.
  • Reply 2 of 2
    I had this happen with the slot load drive on my Cube a few times. I got it out once by pushing the CD the rest of the way into the drive and than ejecting it. Another time I grabbed it with a pair of tweezers.
Sign In or Register to comment.