1ghz TiBook still not charging after PMU reset, anything else I should try?

in Genius Bar edited January 2014
This is one of the final revision TiBooks (1ghz G4, DVI, SuperDrive). I took it with me to Europe for the Christmas vacation, and although it is running on AC power over here, the battery is not charging. I've tried a PMU reset, removing the battery and putting it back in, disconnecting and reconnecting the power brick from the mains and many permutations and combinations of the above. Still no joy. Is there anything else I can try before asking Apple for a replacement battery? This is the first battery problem of any kind that I've experienced...

Edit: Forgot to mention that the battery indicator has the little bolt of electricity to indicate that it is charging, and the power cable connector is showing the green light...but battery power remains at 0% (or is 'calculating' the time to a full charge).


  • Reply 1 of 2
    Get a new battery. Hope it's still under Applecare! Call Apple, thats what they will suggest.
  • Reply 2 of 2
    I kind of figured that's what I'd have to do...although I was hoping there'd be a quick fix that I hadn't heard about. Oh well, thanks all the same...
Sign In or Register to comment.