Locked myself out of my hard drive! (solved)

in Genius Bar edited January 2014
Stupid me. I was playing around with permissions so as to secure my machine before I take it in for service. Unfortunately, what I did was set myself, the one and only user, to have no access to my ENTIRE Macintosh HD!

I realised my mistake as soon as I made it, but by that point I could no longer even select the HD to change permissions again.

Laugh away at my stupidity, but now I cannot get anything but a blue screen to boot up since I have it set up as me, the only user, to log-in automatically.

I suspect that I need to fix things via single user mode (root?) but I have no idea how to go about doing this. Even better would be for me to just be able to get access to my regular admin account and change permissions from there. Any help????


  • Reply 1 of 1
    gabidgabid Posts: 477member
    Mods: feel free to get to get rid of that "Urgent" part of my title.

    Through sheer experimentation I seem to have solved my problem. By repairing permissions off of the install disc (I'm running Panther), I seem to have reset permissions to the standard read/write ones and I can now log-in and work away no problem. So while my crisis is averted, I'm now curious to know why exactly this solved my problem.

    That'll show me for posting in a panic
Sign In or Register to comment.