iPhoto 4 crashes when using alias to iPhoto folder

in iPod + iTunes + AppleTV edited January 2014
I think I've found a bug.

My wife and I have separate accounts in Panther, and to share the iPhoto folder I created a picture folder in 'Users/Shared' and then set aliases in each user User folder called 'Pictures'.

Worked fine with iPhoto 3, but her access crashes under iPhoto 4.

My access worked fine, and I transferred 1100+ pictures ok, and turned off drop shadow for max speed.

Her access loads the rolls, then crashes.

I've copied the 'com.apple.iPhoto.plist' from my library to hers, but to no avail. The same happened with a third user account I tried. Any other suggestions I could try?

I've sent a crash report to Apple (it came up automatrically after the crash), but do they read 'em.

TIA, Santa


  • Reply 1 of 5
    haraldharald Posts: 2,152member
    Sounds like a permissions thing.
  • Reply 2 of 5
    jbljbl Posts: 555member
    This was discussed someplace else. One of the files iPhoto uses to keep track of where things are gets its permissions reset to 600 every time you run it. As a result the next user doesn't have proper permissions. I guess they want you to share files by using Rendezvous.
  • Reply 3 of 5
    jbljbl Posts: 555member
    Actually, the discussion was on OSXHints
  • Reply 4 of 5
    Had the same problem and fixed it (with the help of Mac Genius) simply by moving the Pictures folder and re-linking to it from both accounts. iPhoto4 apparently has a new way of doing things all its own. In any case, that's all it took to fix it for me.
  • Reply 5 of 5
    G'day from Oz, people.

    Thanks for the replies, at least I know what's going on.

    Sport73, I tried your suggestion, but my set up still crashes, thanks anyway.


Sign In or Register to comment.