DHCP/Router Problems on School Network

Posted:
in Genius Bar edited January 2014
Hi all,



I figure there will be somebody here with more knowledge than the tech support staff at school (whom I've already consulted twice and gotten nowhere). Here's the situation: I came into school Monday morning, plugged my PowerBook into its usual ethernet connection (they use a proprietary connector here to make things easier/cheaper, so I run that connector to a switch, then CAT5 cable from the switch to my PowerBook). Anyhow, I could not get a proper internet connection, so looking to the network prefs. pane, under TCP/IP, I was receiving an IP address from the (a router?? at this point, I dunno from whence) router, but there was no IP address listed for the router itself. So I tried using the default gateway IP address that my roommate was getting on his Windows PC. OS X popped up "this router is not available on this computer's local subnet."



What in the heck is going on? Is that because we're using a switch to connect both computers (roommate hasn't got a cable yet)? Is the problem on my end, or the school's IT end? (I tend to think it's on the IT dept.'s end because SOMETHING had to change over the weekend, and I can get a proper VPN connection with the wireless net through a local campus organization based close to my dorm).



Please clarify, IT magicians. What could they have changed so that Macs can't see the router, but PCs can? And what could have happened on my machine, if anything?



P.S. --- I just tried again, connecting my proprietary cable directly to my PowerBook, and I got the same result. No router address, no connection. But PowerBook seems to want to conceive an IP address from somewhere. Help.

Comments

  • Reply 1 of 3
    Strange.



    What is the IP you get? 169.xxxxxxx? That just means you're not getting a connection. Try plugging a PC into the same port. If that works, then something is majorly screwy. You should also make sure your ethernet port works.



    Does your school run DHCP? I would presume so. In this case, don't put anything in the gateway setting.
  • Reply 2 of 3
    dobbydobby Posts: 796member
    In your TCP/IP config do you see the subnet mask as well?

    Is the ip address for the router you have added in the same subnet as your ip address?

    If you do an arp -a you should see some ip's and one should be the DHCP server that provided the ip address (which could also be the router).

    Generally the first few ips or the last few ips are the routers.

    For help on subnets see http://www.learntosubnet.com/



    Dobby.
  • Reply 3 of 3
    fred_ljfred_lj Posts: 607member
    Okay ---- it's not my computer. I went to our university center and plugged into a drop there. It's fine through a hard connection.



    But now my roommate's PC has stopped getting a real IP (outisde the comptuer-supplied 169...etc.) also, so I guess it may just be our room
Sign In or Register to comment.