Epson EPL 5700i problems...

in Genius Bar edited January 2014
My dad has an epson EPL 5700i laser printer. He bought it refurbished about a year ago, and it has recently crapped out.

Here is his description of the problem:

I replugged in the laser printer (Epson EPL-5700i), downloaded a new driver and it still doesn't work. Here's what happens: the file to be printed starts to load into the printer software (I can view this from the printer control program) but never gets fully loaded. The little

bar never quite gets all the way to 100% and the file won't print. Is there a way to zap the printer's memory or processor and start over? If not, I think this printer is history. It cost $200 refurbished so I got a good deal, but I would like to check out all options before it sits in the alley.

He's using an eMac 700 mhz running 10.3.2

I was home a few weeks ago, and I tried several things... I installed the driver on my computer (G4 PowerMac single processor 867 mhz 10.3.2)and tried to print from my computer and it didn't work either...

any ideas?
Sign In or Register to comment.