X11 Wm

Posted:
in macOS edited January 2014
Ok guys its late here so ill keep it short, heres what i want to do........



I have 3 montiors on one machine, on the third montitor i want to be a screen dedicated for X11 stuff, i have got blackbox WM to start auto with apples X11 on panther, the only prob is the WM dock gets placed on my main monitor where my OSX dock is and then spans across the 2nd monitor but not the third which is the target im after.

Is there away to specify which monitor X11 gets preference over?

can i tell X11 to start up on the third monitor ?



Cheers, im off to bed.

Comments

  • Reply 1 of 6
    cubedudecubedude Posts: 1,556member
    I think you set that in XII prefs, don't you?
  • Reply 2 of 6
    Quote:

    Originally posted by CubeDude

    I think you set that in XII prefs, don't you?



    cant see anythig about displays in /private/etc/X11/xinit/xinitrc



    I was hopeing it is just a command i can put in my .xinitrc file in my home directory but i'm not all that clued up on that



    I'm going to check Xfree's site and see if i can come up with anything.



    come on all you X11 people out there surely there must be a way?
  • Reply 3 of 6
    ok i got it, all i had to do was edit the .blackboxrc file and set the dock to bottom left and reduce the percentage to 25 %.



    But i would still like to know if i can set up X11 to just use that 3rd monitor and not spill onto the other 2, It's on a seperate vid card so if anyone is in the know please do tell. \
  • Reply 4 of 6
    pbpb Posts: 4,233member
    Just a hint: in XDarwin, there exists the option to set the X11 display number. But I don't know if it does exactly what do you want to.
  • Reply 5 of 6
    that sounds promising, cheers i'll look into that.

    The closest i've come so far is to set -geometry settings in me .xinitrc file apparently X11 in OSX uses (0,0) as the main display and anything to the left is set at a negative, so i'll fiddle with that tomorrow and if that dont work i'll look in too and see what i can dredge up about setting the display number.



    there has to be a X11 guru hiding around somewhere
  • Reply 6 of 6
    Just for those who r bothered or who have the same dilema i came across a sort of a fix.



    If you have a .xinitrc file in your home directory rename it too xinitrc(without the .) then run X11.app and from the xterm type

    /usr/X11R6/bin/xinit /Users/cyb/xinitrc -- /usr/X11R6/bin/Xnest :3

    -geometry 1280x1024



    where cyb is your user name, geometry your screen size and :3 the screen number you want.



    What this does is open a rooted X session within a window.
Sign In or Register to comment.