Folder Settings .DS_Store ?

in Genius Bar edited January 2014
My Hard Drive always looks like this:

I want it to stay like this:

It does this with every folder except the ones within my home folder. I am an administrator of the computer too.

Does anyone know how to fix this?


  • Reply 1 of 2
    thuh freakthuh freak Posts: 2,664member
    iirc, you can fix this by removing the appropriate .DS_Store file. the only way i know how to do this is in terminal, since the finder hides "dot files". So, open up Terminal (located in /Applications/Utilities). since we are going to be working on the top (or "root") directory (based on the pic you gave, i assume you intend to alter '/'), this is going to require "superuser" (also called "root") permissions. the following command will delete the .DS_Store file:

    sudo rm /.DS_Store

    After you type that in terminal (and hit enter), you will be prompted for your password. As you type it, it will not echo on screen, but rest assured, it is being absorbed. Hit enter after finishing your password, and the command will proceed. I'm pretty sure that once the .DS_Store file is gone, the folder will use global settings. You should be very cautious with the command above, as incidentally adding a few erroneous keystrokes could wipe out your hard drive. I suggest you close out terminal when you are finished, lest you get curious with a bad "sudo rm" command.

    If you want to fix other folders similarly, you would do this:

    rm "/path/to/folder/to/change/.DS_Store"

    Anywhere inside your home directory won't require the "sudo" at the beginning. If that command doesn't work, and messages somethign about permissions, sudo is probably required. (Sudo is a command which asks for your password, and grants superuser access.) Also, the /path/to.... should be replaced with a unix-style path to whatever folder you are trying to fix (Unix-style paths use slashes, '/', to separate directories. Also, the whole /path.../.DS_Store is in quotes, incase you want to work on a folder that has white space in the name, or other special characters. If there is no white space, you can usually remove the quotes).

    If you don't know the full unixy path of the folder you'd like to fix, you can do this: type in


    (there is a space after "rm") Then drag the folder onto the terminal window. BUT, before hitting enter, type


    Now the terminal window will have the full path (possibly with some oddly placed forward slashes, don't mind them. it's another way to get around the white space problem mentioned earlier). Then you hit enter. (Again, if you get a permissions problem, repeat the step but preceed "rm" with "sudo").
  • Reply 2 of 2
    nanonano Posts: 179member
    Thank you very much.
Sign In or Register to comment.