Networking with Windoze

Posted:
in Genius Bar edited January 2014
Hi all



Have taken a step backwards and bought a cheap little PC for a few PC-specific things that needed doing (why is bloody PowerPoint not compatible...).



Anyhow, trying to netwok it with the Mac - iMac running 10.3, PC has Windows XP Home.



Have got them wired with a crossover cable, and tried to run various instructions found on the 'net. Have run the 'home network' wizards etc on the PC, done the double clicking on SMB then 'Connect to server' thing on the Mac.



When PC is hooked up to the pnone line, Mac (bless it) can access internet no problem through PC, doesn't work other way round.



The PC can see an enabled LAN connection, but doesn't appear to see the Mac.



Can see no evidence of the PC on the Mac. When I browse for the workgropu it can't find anything, nothing under Network in Finder.



All I want to do is to see shared files on the PC, send a few to the PC and access internet from PC through the Mac, which will remain the main machine.



I have a sneaking suspicion that I need to waste more $$ on XP Pro, but am keen to be told otherwise, ideally with idiot-proof instructions...



Will be impressed if someone can help me to get it to work.



Amusingly, PC shipped with at least 2 dead pixels, dead internal modem, out of date software, millions of 'free' ISP deals, and has crashed twice this evening etc, etc. Missed them like a hole in the head!



Thanks in advance.

Comments

  • Reply 1 of 17
    x xx x Posts: 189member
    Quote:

    Originally posted by genesurgeon

    Hi all



    Have taken a step backwards and bought a cheap little PC for a few PC-specific things that needed doing (why is bloody PowerPoint not compatible...).



    Anyhow, trying to netwok it with the Mac - iMac running 10.3, PC has Windows XP Home.



    Have got them wired with a crossover cable, and tried to run various instructions found on the 'net. Have run the 'home network' wizards etc on the PC, done the double clicking on SMB then 'Connect to server' thing on the Mac.



    When PC is hooked up to the pnone line, Mac (bless it) can access internet no problem through PC, doesn't work other way round.



    The PC can see an enabled LAN connection, but doesn't appear to see the Mac.



    ...



    Amusingly, PC shipped with at least 2 dead pixels, dead internal modem, out of date software, millions of 'free' ISP deals, and has crashed twice this evening etc, etc. Missed them like a hole in the head!



    Thanks in advance.




    I recently hooked up my new iBook to my crap ass PC and got it to work kinda the way you went about it except my crap-ass PC had crap-ass ME on it (no pun intended). Here's a little more detail of what I did to get mine working...



    1) I bought a cross-over cable and hooked the two computers up

    2) Set my PC's NIC card to having an IP address of 192.168.0.1 (You can set it to have any IP, I believe)

    3) Ran Home Networking wizard on the PC

    4) Manually set my iBook's IP address to 192.168.0.2 in the Networking prefereces

    5) Turned file-sharing on in my iBook. (I don't think that matters because all I wanted to do was get files off my crap-ass PC.)

    6) Open finder window and click on "Network".



    BTW, after I clicked on network, I had to wait a while before my iBook saw the crap-ass PC's files (don't know why) I thought it wasn't working at first but then suddenly I saw my crap-ass PC on my iBook.



    One other thing...



    You can check to see if your computers are talking to each other by...

    1) Opening the command prompt on the PC and type "ping 192.168.0.2" or your Mac's respective IP address.

    2) Opening up Terminal and type "ping -c 4 192.168.0.1" or your PC's respective IP address.



    the "-c 4" tells the terminal to only ping your PC 4 times. The PC's command "ping" defaults to 4, but on the Mac's terminal it will ping indefinately until you force it to stop with some key command I can never remember.



    If your computers are talking to each other they should each send packets and receive packets with 0% loss. If that works then try waiting a while after you click on the "Network" icon in the sidebar of your finder window.



    Let me know if that helps.



    Regards!
  • Reply 2 of 17
    neutrino23neutrino23 Posts: 1,525member
    In case the PC doesn't show up in Network then try the following.

    From the Finder select Go/Connect to Server.



    Type in



    smb://computername/sharedfoldername



    This should bring up the dialog for logging into your pc. Instead of computer name you can also use the IP address.



    Another way to check that the pc is visible is from the Terminal type:



    findsmb



    to see pcs that Network won't show you.
  • Reply 3 of 17
    Thanks for the replies folks.





    In case the PC doesn't show up in Network then try the following.

    From the Finder select Go/Connect to Server.



    Type in



    smb://computername/sharedfoldername




    Did this, timed out and Finder hung!





    Another way to check that the pc is visible is from the Terminal type:



    findsmb



    to see pcs that Network won't show you.




    This was interesting - found the IP address for the Mac but with the workgroup name I'd entered on previous botched attempts. No sign of PC though.



    So, no progress so far. Any further thoughts? I can't help but think that I need to do something to the PC (apart from the obvious with a sledgehammer).
  • Reply 4 of 17
    Forgot to add that I found the PC's IP address thrugh the LAN properties tab and entered that into Go/Connect to server.



    It looked for a couple of mins but timed out having failed to find server.



    Mind you, watching the LAN status on the PC revealed that it was connecetd to something and receiving Packets...
  • Reply 5 of 17
    x xx x Posts: 189member
    Quote:

    Originally posted by genesurgeon

    Forgot to add that I found the PC's IP address thrugh the LAN properties tab and entered that into Go/Connect to server.



    It looked for a couple of mins but timed out having failed to find server.



    Mind you, watching the LAN status on the PC revealed that it was connecetd to something and receiving Packets...




    Don't use the "Connect to Server" feature. That won't work. Did you try connecting the way I said?



    Regards!
  • Reply 6 of 17
    dobbydobby Posts: 794member
    try

    smb:/[email protected]/sharename

    you need to re-enter the username in the correct case (seems to default to uppercase).



    Dobby.



    Oh Yes, check you can ping the pc first. if you can't do this (and you haven't any firewall shit on the pc ) then you can't see it anyway.

    EDIT -

    And another thing. Make sure that smb is enabled in apps-utils-directory access.
  • Reply 7 of 17
    Thanks for all the advice - great to have such support out there.



    Well, haven't given up. Yet.



    The Mac can ping PC, PC can't ping Mac.



    Lots of packets going both ways.



    Mac still not appearing on PC network (not a disaster), but when I try to log on to the PC from the Mac, it sees the shared PC folders, appears to let me log on (no matter what usename is entered), the folder appears on Finder, but then it can't see the contents. A couple of seconds later, when clicking on it, the warning "Alias filename could not be opened ......"



    Getting there, but still missing something. Any further thoughts?
  • Reply 8 of 17
    mr. hmr. h Posts: 4,700member
    Quote:

    Originally posted by genesurgeon

    Getting there, but still missing something. Any further thoughts?



    EDIT: oops, I just noticed that you'd got a bit further than I thought. I'm not sure what's going on with your setup, so I've left my original post in tact below in case any of it helps.



    O.K., here goes:



    I've never used a crossover cable, just a hub, Panther and Windows 98/2000. I reckon these instructions should work. I don't know where Win XP keeps all of its settings, I'll just have to assume you do.



    Set the PC's IP address to 192.168.0.2, the subnet mask to 255.255.255.0 and the router/gateway to 192.168.0.1



    You have implied in your previous posts that you use dial-up to access the internet on your Mac. If your ISP has provided you with DNS server addresses, enter those as DNS servers for your PC.



    set the workgroup to whatever you want to call it.



    make sure that the folders/hard drives on the PC are actually being shared by right clicking on them and selecting sharing... in the contextual menu.



    On the Mac, set the Ethernet IP address to 192.168.0.1 and the subnet mask to 255.255.255.0. You should be able to leave the rest blank.



    Launch "Directory Access" which is in the utilities folder, and authenticate by pressing the padlock icon in the bottom left corner of the window. Make sure that SMB is checked, then select it and press configure. In the sheet that appears, enter the workgroup name that you chose on your PC. Apply the changes and quit Directory Access.



    Now try pinging PC to Mac and visa versa. If it isn't working then there's probably something wrong with the PC's network settings. Is it still as complicated in XP as it is in previous versions of windows?



    If both machines can ping each other, the workgroup should show up in the finder. If it doesn't you can connect to the PC by going to "connect to server..." in the "go" menu and typing smb://192.168.0.2 I know this works because I've done it loads of times myself.



    If this is working, then you can make an attempt to share the internet connection:



    Go to the sharing pane of system preferences

    Choose the internet tab

    In the drop down menu next to "Share your connection from:" choose "Internal Modem"

    In the box below "to computers using:" tick "built-in ethernet"

    Dial-up from your mac

    Once mac is connected, PC should be able to access the internet. The biggest problem I've had so far with this is DNS, in that the PC can't find the IP addresses for domain names entered into web browsers and the like.



    Good Luck!



    P.S. if anyone knows how to get a workgroup to show up over an airport network, that would be great. With a Win98 PC, when I connect from my PowerBook over ethernet using a hub, the workgroup shows up in the finder just fine. If I connect my Airport base station (not extreme) to the hub, and have it set up as a bridge, and connect to that with my PowerBook, I can no longer see the workgroup in the finder but can still connect to the server using "connect to sever..." and the PC's IP address. Do I need to change my config to use 10.0.1.x type IP addresses (rather than 192.168.0.x) and port forwarding?
  • Reply 9 of 17
    Wow - that was thorough!



    Followed it to the letter, internet access through Mac working & findsmb finds the PC.



    Unfortunately unable to get beyond this. PC can now see Mac on the workgroup (but not connect - I think the Mac's name is too long!)



    Still only partly mounting PC folders in Finder - it sees them, lets me log on but they don't reveal their contents. Only shows the ones enabled for sharing, so that's not the problem.



    Finder still shows nothing in Netwrok, bar the Mac itelf.



    Still have a bad feeling that it has a lot to do with XP....
  • Reply 10 of 17
    mr. hmr. h Posts: 4,700member
    Quote:

    Followed it to the letter, internet access through Mac working & findsmb finds the PC.



    great! at least something's working.



    Quote:

    Still have a bad feeling that it has a lot to do with XP....



    Me too. I had a brief poke around the internet to try and solve the minor issue I'm having and it seems that lots of people are having problems sharing stuff XP to 10.3.3.



    I've got a few more suggestions that you can try:



    1.) Make sure the PC and Mac names are a maximum of 8 characters each.



    2.) I've had a bit of a nightmare trying to set up users and groups on a Windows 2000 PC, so I imagine it's pretty bad in XP too. The problem you are having could have something to do with authentication. Try and set it up so that the PC requires a user name and password to be entered in order for someone to be able to share files with it (right click, go to "sharing..." then investigate all the available settings).



    3.) On your Mac launch Keychain Access from the Utilities folder and delete all entries that relate to your PC.



    4.) Now when you try and connect to the PC, you should get an authentication box that pops up. Enter the user name and password that you set up on the PC.



    If this doesn't work, you'll need to find a friend who is a Win XP "Power User" to help you set up the PC properly. Alternatively I could post details about using FTP and VNC viewer, an inelegant solution that will at least allow you to copy stuff from PC to Mac and visa versa.
  • Reply 11 of 17
    Quote:

    Originally posted by X X

    ..snip...



    on the Mac's terminal it will ping indefinately until you force it to stop with some key command I can never remember.



    ..snip..



    Regards!




    CTRL-c

    (this is true for any unix command line, with most programs)



    -walloo.
  • Reply 12 of 17
    sport73sport73 Posts: 438member
    Why not just enable internet sharing on the Mac?



    Presumably your PC is set to receive and IP via DHCP, so enable internet shaing on the Mac and it will become a DHCP server assigning an IP to the PC.



    Once the PC is booted, click Start->Run and enter ipconfig. It should show it's IP address as 192.168.1.xx



    Then launch internet explorer and input afp://<mac IP address./username and see if you can share files etc.
  • Reply 13 of 17
    Bloody h***!



    This is why I really switched to Mac!! (Err, that's for the great advice and support, still haven't sorted file sharing - but nearly there!!)



    Anyway, many thanks from a non-IT pro for the valuable comments, looks like I've got a few things to try this weekend.



    Got a feeling it's gonna work for me.....
  • Reply 14 of 17
    sport73sport73 Posts: 438member
    Noticed your comment about seeing PC folders but contents not being available.



    There's a simple fix that should work to solve that...If you can get to that point again (Logged onto the PC, able to see folders etc., but unable to access files), do the following...



    On the Mac, move the PC folders into the trash (Don't worry, they're not deleted...You're just telling the Mac to 'disconnect' from the shares). Also, trash the PC from within finder (this will disconnect you from all of it's shared folders etc.)...



    Then, reboot the Mac.



    When it comes back up, try reconnecting to the PC within finder. I bet all of you folders and files become visible.



    I had this problem when networking to a Windows XP box. Folders were visible, but the contents were empty...By trashing them, everything reconnected and I've not had any issues since.



    Good luck!
  • Reply 15 of 17
    gargoylegargoyle Posts: 660member
    sneaky windows admin trick....



    smb\\\<windows machine ip / name>\\C$



    When prompted, enter the pc's Administrator username and password.
  • Reply 16 of 17
    gargoylegargoyle Posts: 660member
    Oh, when doing network tasks - its good practice follow these guides...



    1.) Private networks that are going to connect to the internet should only use ip addresses in the ranges 192.168.x.x, 10.x.x.x 169.x.x.x (last one might be wrong).



    2.) Configure your IP addresses and PING the machines from each other before you try anything else. If you cannot ping both ways - there is no point in moving onto the next step or trying any other commands like SMB\\\



    This could save you a lot of time.
  • Reply 17 of 17
    cosmonutcosmonut Posts: 4,872member
    Does anybody else think this whole process should be WAY easier than this? I thought the industry was past all this crap!



    The other day I tried to share my iTunes music with my housemate's -- from my Mac to his PC. It ended up that I could see his songs but he couldn't see mine. WTF!?



Sign In or Register to comment.