HELP! DSL modem and Powerbook don't like each other

in Genius Bar edited January 2014
My trusty powerbook 800 is having issues with a new dsl modem i just got. and of course my ISP doesn't have OS X technical help - the tech guy said it should work but sorry can't help you. So i tried. i fiddled with the network settings and nothing, nada. the modem is plugged in with ethernet and i have my settings on DHCP.

i know its impossable to help out without sitting at the machine and seeing exactly what i've got but i thought i might just be missing something obvious - i'm not a real techhead but i'm no green first timer either.

It looks so easy to get this thing running on windows in the manual that came with the modem, so i'm thinking - switch . . . . just kidding folks, not on your life, i'm sticking with apple and just hanging out for those powermac updates.

so thanks for any ideas you guys can throw my way.


  • Reply 1 of 3
    cam'roncam'ron Posts: 503member
    are u using a router? if not, dsl is through PPPoE. enter the isp info for that instead.
  • Reply 2 of 3
    yeah, the modem has a router address. so i guess so. i forgot to say i've got OS 10.3.3 too.
  • Reply 3 of 3
    machemmachem Posts: 319member
    What I've had to do is explicitly put the DNS addresses in my OS X settings. Doesn't seem like I should have to, but if I don't, no dice.

    I currently have DSL -> Hub -> AirPort -> Powerbooks, but same thing worked if the Hub and/or AP were removed.
Sign In or Register to comment.