USB and Ethernet issues from sleep

in Genius Bar edited January 2014
I have a 6 week old 15" Pb. This issue has only been going on for the last 4 days.

When I wake the computer up from sleep, pop the lid up, my USB stuff is not recognized. I have a 4 port hub with my external keyboard, wireless mouse, zip drive, and printer hooked up. (When I put the computer to sleep, I disconnect from the internet, make sure its disconnected fully, and put the lid down.)

I am also having a problem with the ethernet not being recognized when I wake the computer up from sleep. I can not run "internet connect" to get the computer to connect to the internet. I have a Speedstream 5100 with DSL to connect. (After sleep the power light and DSL light are on, but the ethernet light is not on -- as it should be with the ethernet cable being hooked into the computer.) What happens is that I click the connect button, and nothing happens, however, if I go through a program, like I'm using Safari right now, it will connect when I try to open a page, or if I use Mail to check my email, it will do that and leave me connected.

Mind you, when I restart the computer, it recognizes everything just fine. All the lights are on in the right places etc.

Both the ethernet and the hub are hooked in on the same side of the machine, not sure if that is any indication, but I moved the USB plug to the left hand side of the machine,and its still not recognizing it.

I just looked in System Profiler, it is recognizing it there, and showing all the devices. However, none of the lights are on, on the hub.

The last thing I checked the FAQ, deleted cashe, ran disk fix utility, etc.

Any help anyone? Thanks so much....


  • Reply 1 of 3
    remryremry Posts: 10member
    Ok, did a search here to no avail....

    but went over to MacNN and did search there, and there was a lengthy thread there, about when sleeping (for more than a few minutes) the USB 2.0 ports dont always work quite right coming out of sleep.

    the suggestion, have the computer wake from sleep and ask for a password.

    So I've set the computer to ask for a password, which I'm willing to try.

    I am hoping that will also solve the ethernet recognition as well.

    If anyone has any other thoughts or info...I'm going to put the computer to sleep right now, as a trial, and come back in a little while and see what happens.
  • Reply 2 of 3
    remryremry Posts: 10member
    ok, I put the computer to sleep for an hour, came back had to log in and still had the lack of USB functionality as well as not being able to log into the internet, so I restarted the computer, again, all is well....

    I'm not sure what the next step is for this....
  • Reply 3 of 3
    remryremry Posts: 10member
    Here's the update, I put my computer to sleep and came back, and had to restart it. I called Apple, they had me reset the power management, which seemed to help, at least the first time that I went to wake it back up this evening....but a few hours later (I went out to dinner and closed the lid to put it to sleep) when I went to open the lid, the same thing happened again, with no USB or ethernet.

    A simple restart worked however.

    I'm debating taking a run to my local Apple Store and having them run some tests on it, see if i can cause some sleep issues in front of them, as the Apple guy on the phone said he had never heard of this problem before, I only live a short 30 minute drive away from the store, so its not too bad of a deal for me.

    Thanks for listening....I hope this info helps someone, sometime!
Sign In or Register to comment.