10.3 Can't see new HD but 9.2 Can

in Genius Bar edited January 2014
I just bought this 120GB HD for my Power Mac 450. I installed it as a slave and booted up the Mac in 10.3

When I logged in I got this message:

"You have inserted a disk containing no volumes that Mac OS X can read." To continue with the disk inserted, click Ignore."

I tried to initialize it and when I clicked erase I get this message:

Disk Erase failed with the error:

The underlying task reported failure on ext

It doesn't even show the proper drive size. But here's where it gets weird. OS 9 sees the drive fine and even formatted it properly. So I did that in 9.2 and rebooted back into 10.3 and everything was fine....until I rebooted again! The original "no volumes" message came up. I booted back into 9.2 and it was fine, back to 10.3 and fine again. Just to be sure I shut down and went back into 10.3 and the "no volumes" message comes up.

Basically the drive works fine in 9 and works once in 10.3 after booting into 9. But it won't permanently work in 10.3 for some reason.

Has anyone seen anything like this before? I really hope this is just something stupid I'm overlooking.



  • Reply 1 of 10
    kickahakickaha Posts: 8,760member
    Is the drive HFS or HFS+? 9 reads both. X wants HFS+.
  • Reply 2 of 10
    kickahakickaha Posts: 8,760member
    Also, what family of PowerMac is it? Not a Rev A B/W by any chance? If so, you're probably not going to get it to work without buying a PCI ATA card. That's what I had to do.
  • Reply 3 of 10
    willoughbywilloughby Posts: 1,457member
    It is the original Power Mac G4 450.

    When I put the hard drive in it was from the factory so it wasn't formatted at all. When I formatted it in 9.2 I think I used HFS+ but I can't remember. But shouldn't 10.3 have let me format it from the beginning? It didn't.

    If I didn't have 9.2 I wouldn't be able to use the drive at all.

    If 9.2 works fine, why would I need a PCI ATA card? But its not a Rev A B/W anyway. So hopefully thats not the problem. \
  • Reply 4 of 10
    kickahakickaha Posts: 8,760member
    No, you should be fine with that machine.

    Sounds like a master/slave cabling problem to me. What are the settings you have on the two drives? IIRC, having either drive on the 'auto' setting screws it up.
  • Reply 5 of 10
    willoughbywilloughby Posts: 1,457member
    I didn't touch the original 20 gig drive. I set the new drive to slave with the jumpers. I checked the MFrs website to be sure the jumpers were set right.

    I also just realized that Disk Checker (or whatever it's called) shows the drive as having 0 bytes. Uh oh. That can't be good.

    Oh and thanks for your help so far
  • Reply 6 of 10
    dmband0026dmband0026 Posts: 2,345member
    Try setting the jumpers on the second drive to cable select, if that doesn't work, try putting them both on cable select.
  • Reply 7 of 10
    kickahakickaha Posts: 8,760member
    Actually, that's the 'auto' setting I was thinking. IIRC, it wasn't until the G5s that that worked correctly.
  • Reply 8 of 10
    formerlurkerformerlurker Posts: 2,686member
    Check the jumpers on your original drive - are they set as master, slave, or cable select? If they are cable select (as I suspect), then the new drive needs to be cable select also.
  • Reply 9 of 10
    willoughbywilloughby Posts: 1,457member
    The original drive was master but I tried cable select anyway and the Mac couldn't see the 2nd drive at all, not even in OS 9.

    The thing that bugs me the most is that 9.2 can see the drive fine but 10.3 seems to have problems with it. If neither could see it than I would just send the drive back.

    I must be missing something stupid. Maybe I can put the 2nd drive on the same cable as the DVD-Rom? Would that screw things up in anyway? Its probably worth a shot....
  • Reply 10 of 10
    willoughbywilloughby Posts: 1,457member
    So a funny thing just happened....

    I was using the drive in 9.2, copying files from my main HD to the new drive. I wanted to see if I could read/write those files in 10.3. Well in the middle of copying a fuse blew in the house! D'oh! I thought I would have lost everything....but it seemed ok and now I can actually see the drive in 10.3! How weird is that!

    The only thing is...the machine seems much slower. Especially booting. My boot time seems to have tripled.

    Any ideas on that one?
Sign In or Register to comment.