Browsing the network

Posted:
in macOS edited January 2014
I just purchased a newer G4 to replace my upgraded Blue & White G3. I put the G3 in another room and hooked it up to the ethernet network, turned on File Sharing and AppleTalk and went over to the G4 to hook up to the G3 to bring over my files.



Problem is, nothing shows up when I browse the network in the Finder. The only way I can connect to the G3 is by manually entering it's IP address in the "Connect To Server" dialog box. I can even connect to it via VPN.



Both machines are running 10.3.3. I can do this at work, but not at home for some reason (nearly the same setup: a G4 to a G3). What could I be missing?

Comments

  • Reply 1 of 11
    sroachsroach Posts: 105member
    Couple things to try:



    1.) is the firewall turned off, maybe stupid but it's worth checking.



    2.) can you ping each other, try pinging one machine then go to the other machine and ping it.
  • Reply 2 of 11
    jabohnjabohn Posts: 556member
    Quote:

    Originally posted by sroach

    Couple things to try:



    1.) is the firewall turned off, maybe stupid but it's worth checking.



    2.) can you ping each other, try pinging one machine then go to the other machine and ping it.




    I don't have Mac OS X's firewall activated.



    The problem isn't that the 2 macs can't connect - because I can connect by manually entering the IP address and I can connect via VPN - the problem is that the machine should show up in the network browser, but it doesn't.
  • Reply 3 of 11
    Quote:

    Originally posted by jabohn

    I don't have Mac OS X's firewall activated.



    The problem isn't that the 2 macs can't connect - because I can connect by manually entering the IP address and I can connect via VPN - the problem is that the machine should show up in the network browser, but it doesn't.




    I've noticed the same thing. I just haven't had the time to figure out what the problem is.
  • Reply 4 of 11
    dobbydobby Posts: 796member
    Check in Directory Access (under apps/utils) that appletalk is also checked.



    Dobby.
  • Reply 5 of 11
    vox barbaravox barbara Posts: 2,021member
    Quote:

    Originally posted by dobby

    Check in Directory Access (under apps/utils) that appletalk is also checked.

    Dobby.




    There is no app called "directory access" in my apps/utils folder. Or do you mean something else? I had the certain feeling you mean "netinfo manager.app". So i opened that app, but couldn't manage to find any pane where to check or uncheck "appletalk". Could you have a look on this issue please?



    best
  • Reply 6 of 11
    staphbabystaphbaby Posts: 353member
    Quote:

    Originally posted by ThinkingDifferent

    I've noticed the same thing. I just haven't had the time to figure out what the problem is.



    This may sound stupid, but what are the IP addresses for the two machines: have you put them on the same subnet? How are they routed (are they just plugged together with a single cable, or are they both being routed by a dsl modem/router or whatever)?



    Appletalk doesn't need to be on to do ZeroConf networking; in fact, it's off by default in 10.3...



    Of course, one slightly kludgy way around this is either to make the ip address a favourite in the connect to server dialog box, or make an alias to it on your desktop and just open that every time you want to connect (these are actually my personal preferred options, because browsing to a server seems an enormous waste of time when there's only 1 or 2 machines to choose from).
  • Reply 7 of 11
    kickahakickaha Posts: 8,760member
    Quote:

    Originally posted by Vox Barbara

    There is no app called "directory access" in my apps/utils folder. Or do you mean something else? I had the certain feeling you mean "netinfo manager.app". So i opened that app, but couldn't manage to find any pane where to check or uncheck "appletalk". Could you have a look on this issue please?



    best




    Um, which version of MacOS X *are* you running??
  • Reply 8 of 11
    vox barbaravox barbara Posts: 2,021member
    Quote:

    Originally posted by Kickaha

    Um, which version of MacOS X *are* you running??



    Um, ... er .. me sorry. There is an app called "dir. access" of course. Didn't see it at first glance and answered way tooooo fast. \



    btw, but still, the issue discussed in this thread remains the same for me, although "appletalk" is checked in dir access.





    EDIT: Ah, Jesus, i checked my pb right now and "appletalk" was unchecked in "dir. access".



    BUT how could that be? neither me nor my girlfriend didn't tinker with that app. Frankly i just have launched it twice, just to look what the app is about.



    best
  • Reply 9 of 11
    jabohnjabohn Posts: 556member
    I my case, both machines are hooked up to a LinkSys router, so they are both behind the firewall.



    I'm not at home right now to check Directory Access to see if Appletalk is active.



    Here at work the setup is nearly identical, except the G3 is running OS 9.2, and it shows up after a few seconds in the Network Browser.
  • Reply 10 of 11
    jabohnjabohn Posts: 556member
    I checked on the G3 to see the AppleTalk was enabled (both in Preferences and in Directory Access) and it was not disabled.



    Last night I had wiped the hard drive clean and installed just OS 9.2.2 and the machine still won't show up on the network automatically (enabling connections over TCP/IP and connecting by IP number did work) so it must be something on my other computer.



    No matter now, I sold the G3.



    Thanks everyone.
  • Reply 11 of 11
    davegeedavegee Posts: 2,765member
    Quote:

    Originally posted by Vox Barbara

    There is no app called "directory access" in my apps/utils folder. Or do you mean something else?



    Nope...



    The Utility is called "Directory Access.app" (the .app is hidden) and it's located in the /Applications/Utilities folder. If it's not there then a FULL system reinstall is what I'd do since who know what the heck else might be missing or messed up.



    Dave
Sign In or Register to comment.