Help save the Radio Shack iBook (missing extenion?)

Posted:
in Genius Bar edited January 2014
I was in radio shack today for some parts for another project and I noticed a Tangerine 300 Mhz iBook running 9.2.2 was in for repairs. Knowing the radio shack staff's competency with computers and Macs especially, I started asking some questions. They were more than happy to let me bang around on it. Someone can't get their HP 1210 all-in-one printer to work with it. I corrected a couple of issues but now I'm stuck. Here's the $90,000 question:



It gives me an error message saying that it can't find "Interface Lib--GetComponentResource" and that I might have to install a newer version of this. I don't know if this is a system extension or something that comes with the printer or what. The printer will not un-install or install without it though and none of the printer related programs (that came with the printer) will run either. They all give the same error message.



I've tried to find this file on or a similarly named file on my 9.2.2 Macs to no avail. So far I've only managed to save the iBook owner from being told that he needs to buy more memory. I'd really like to be able to solve this so they don't tell him to buy a Compaq or something. Any thoughts?

Comments

  • Reply 1 of 4
    neutrino23neutrino23 Posts: 1,529member
    Wow, it has been a while since I helped with OS 9.



    I'm not familiar with this printer and don't recognize that error message, but since no one else has chimed in here are my thoughts.



    First of all I would check the basic operation of the powerbook. I helped one friend who couldn't print this way.



    Is there a reasonable amount of free space on the HD?



    Try rebooting with the option key held down to rebuild the desktop.



    Check the hard drive for errors with disk first aid.



    Did it used to work or are they installing a new printer? If it used to print and the above doesn't help then reinstalling the OS and the driver should fix it.
  • Reply 2 of 4
    allinoneallinone Posts: 279member
    Quote:

    Originally posted by Guartho

    Any thoughts?



    Googled on this, and found:



    http://www.monkeybreadsoftware.de/re...042003_2.shtml



    Sounds like the recommended fix is to boot into base extensions and update quicktime.



    Try it and let us know.



    Hope this helps.
  • Reply 3 of 4
    regreg Posts: 832member
    hp is very flacky with their drivers. I would delete all the hp drivers then download the newest. There are 3 different models of the 1210 and for all the functions the download is 55 meg.



    http://h20180.www2.hp.com/apps/Looku...x=7&submit.y=6



    Hopefully they have the cd. I had the same problem with a G95. It would not work when I first tried it with cups. hp did not have the download page for OS10 drivers listed so I had to get the cd. I had to delete my old hp drivers then install the new one before it worked. Since then it has worked like a champ. Hope this helps.



    reg
  • Reply 4 of 4
    guarthoguartho Posts: 1,208member
    Thanks for the help everyone. Turns out that the quicktime extensions were turned off. Once I turned those back on it was just a matter of figuring out how much RAM it really wanted. It recommended 350k, but the printer wouldn't work till I assigned it 40 megs! Oh well, it's working now and the poor guy isn't going to have to spend more cash for more memory.
Sign In or Register to comment.