Router Port Forwarding Woes

in Genius Bar edited January 2014
Argh. I've been fighting with my router and port forwarding for the past few hours now, and have just about given up. I was wondering if anyone would mind looking over how I think it should work and let me know if I've missed anything important...

Here's how I have my system setup: I use DSL, which gives me a dynamic WAN IP. The DSL Modem goes into my Netgear Router, which in turn goes to an iMac (with a static LAN IP).

Now, I want to set up VNC on the iMac so I can help my mom from afar. I poke a hole in the OS X Firewall, and start up the VNC Server (with OSXvnc). Now, through the LAN address, I can connect to the iMac just fine. Great.

So, I go to the Netgear router to set up the port forwarding. I set it to forward port 5900 to my LAN address. I then grab the (current, but dynamic) WAN IP and try to connect from outside the router, but I just get a timeout... I know my ISP isn't intercepting it, as I can access the setup web page of the router through the WAN IP address. It's just that the router refuses to forward.

So, now I've tried all sorts of services (Web, SSH, etc), with all sorts of other fancy stuff, like the DMZ server configured, and letting the router reply to WAN pings, using or not using DHCP for the LAN address, etc. But nothing's worked. So, I resorted to trying to drudge through google, and again, found nothing that worked. My firmware's up to date, too.

So, am I doing anything wrong? Any and all suggestions are appreciated. Thanks!


  • Reply 1 of 4
    gsxrboygsxrboy Posts: 565member
    Ok I think it might go something like this, if your netgear modem is the same kinda setup as mine (DG834G) they dont have a loop back facility in them (so I found out by having the same kinda prob as you), so you cant access the vnc server by using the dynamic ip addy as seen by the outside world (or pointer) from inside the modem, i.e. from your LAN, it will either try to go to the router setup page or will just go wonky and not find anything.. to see if it all works you can vnc straight to the machine with the LAN IP addy and it should spring up, same if you go to the LAN IP in your browser if should fire up the webserving page if you have that turned on in sharing cpanel.. to vnc using your outside world addy you have to be outside the router so to speak..

    I fink thats the problem you are experiencing..

    p.s. sign up to a acc and if your router has the dns bit in it fill in your info there as well it helps greatly with not having to remember your WAN IP which can change..
  • Reply 2 of 4
    Or your ISP could be blocking your listen port. I found this to be my problem.

    I am now bald. Thanks OPTUS
  • Reply 3 of 4
    Don't overlook a bad router too. I have run across them many times. I keep a working one ready to send out to a sales rep in the field.

    I then know it is setup correctly and functional. There have been many weird problems that are often cured by replacing the router/switch. Even our expensive Cisco routers have problems.

    Did you reset the router to factory defaults? If not, try that. You don't need any of that DMZ stuff.
  • Reply 4 of 4
    Can you access your router's config screen from the Internet?
Sign In or Register to comment.