OS Server (10.3) not serving via VPN

in macOS edited January 2014
A friends work is trying to get VPN to go so they can log into their fileserver remotely.. The VPN logs in ok under the username etc but once inside the network they cant actually do much, they can muck around in terminal, but the shared drive (folder) doesnt show up in network etc and they also cannot ping the server machine.. they are frustrated to say the least.. they changed the hostconfig for ipforwarding but that did fix it either..thats about the only clues I had for them.. anyone think of something else they might have missed?


  • Reply 1 of 4
    I tried out the VPN for a while on 10.3 Server, and eventually gave up as it is not really documented at all. I wound up making my own VPN/Router out of an old Wintell box and Devil-Linux. It is really easy and solved the problem.
  • Reply 2 of 4
    in 10.3, you shouldn't have to edit the hostconfig file to enable VPN properly. I can definitely help... it's really quite easy, as long as you know the pitfalls.

    Just give me some more info... what kind of VPN are they trying to set up? PPTP or L2TP? Lemme know that, and I gave give you pointers.
  • Reply 3 of 4
    Thx for the help, they are trying PPTP, (L2TP just wouldnt find the server at all).. VPN clients used to connect were OS10.3 internal and a pc type (dunno the proggy name sorry)
  • Reply 4 of 4
    Sorry this took awhile, I've been really, really busy.

    The thing to keep in mind with PPTP is that the username used to connect to the PPTP server must be in the local netinfo domain, not the LDAP directory. That is the #1 pitfall. The symptom is that you generally get a connection of some kind, but no actually connectivity to the rest of your internal network.

    Here is a good article on PPTP for 10.3 client:


    If you need (or really want) to use your LDAP users for authentication, then you need to follow this article:


    Hope that helps!
Sign In or Register to comment.