Postfix, SMTP Server, Jaguar 10.2.8

in Genius Bar edited January 2014
Trying to install "Postfix" to allow me to send emails using a local SMTP server. I am following the instructions available here:

Postfix Instructions

I hhave downloaded Postfix 2.1.5 from Postfix and then gone through the instructions. On entering the second command


I get the following message:

newaliases: warning: valid_hostname: misplaced delimiter: Chris-Hindss-Computer.local.

newaliases: fatal: unable to use my own hostname

if I then continue and compile Postfix it compiles fine (logged in as Administrator) but when I come to edit in Pico it tells me that it cannot save to the file which I assumed to be a permissions issue. I tried again logged in as the "root" user and this time Postfix had errors on compiling.

Has anyone managed to get this working and established what is wrong. Here are the instructions I am using without the waffle:

sudo touch /etc/aliases # create empty aliases file if necessary



cd Desktop

cd postfix-2.1.5


cd auxiliary/MacOSX

sudo ./backup-sendmail-binaries

sudo ./niscript

cd ..

cd ..

sudo make install

I then follow all default selections, including setting setgid to "maildrop"

pico /etc/postfix/

I then cannot save the changes to

mkdir /Library/StartupItems

sudo ./backup-postfix-binaries

sudo ./activate-postfix

The last two steps fail also.

Any help will be greatly appreciated




  • Reply 1 of 1
    ok by modifying using text edit I got rid of the valid hostname error, which has now been replace by (on typing newaliases with:

    postalias: fatal: open database /etc/aliases.db: Permission denied

    doesn't matter if I add "sudo" before the command either. Haven't tried with being logged in as root. More info for the fire...


Sign In or Register to comment.