system preferences greyed out 10.2.8

Posted:
in macOS edited January 2014
I have a Flower Power Imac 600mhz, 384 ram. I installed X 10.2.8 on one partition and have 9.2.2 on a second partition. I installed all the updates from Apple.

I use DSL for my internet and it connects just fine, no connection problems. My problem is that when the ethernet cable(which is plugged into a SpeedStream modem), is plugged into my Imac (on the side), some of my system preference panels(energy saver, accounts, sharing) are greyed out and I cannot make changes to them (I am the administrator). If I unplug the ethernet cable from the Imac then the panels aren't greyed out anymore and I can make changes or set them as I wish. I have spoken to SBC and they tell me that my modem is compatible with os x and that it is a hardware problem, but I ran the hardware test cd and all is fine , however, when I am booted into os 9.2.2 there are no problems whatsoever, there never was any problems with my modem being plugged in when using os 9(i have had dsl for 6months). Does anyone have any ideas about this? I have reinstalled OS X three times, and am running os x and os 9 without any 3rd party apps installed(I do have an epson printer, but no problem when it is plugged in), so both are clean installs, I have exhausted this message board and a couple others, by reading most posts, trying to find a similar problem to no avail, I would appreciate any input.





Vicki

Comments

  • Reply 1 of 17
    pbpb Posts: 4,233member
    Now this is strange. You can always try to repair privileges, or install OS X alone in the machine without partitioning the hard drive. Or reinstall both OS X and OS 9 after erasing completely and partitioning again the hard drive.



    Are you sure you are the administrator? Usually, your symptoms indicate that you don't have enough privileges to modify some system preferences.
  • Reply 2 of 17
    It could be as simple as looking for a padlock icon in the System Prefs pane. This will ask you to authenticate with your password.



    If it's not something that simple, then I'd try repairing permissions, and then, lastly, looking for the system prefs cache in your Library/Caches folder.
  • Reply 3 of 17
    davegeedavegee Posts: 2,765member
    This sounds like "Workgroup Manager" at work... it's something that's part of OS X Server that allows the person running the server to 'lock-out' certain aspects of the computers on the network - from turning on/off specific preference panels to allowing/denying certain applications from being run.



    Is your Mac part of a campus network (or was it at one time)?



    Dave
  • Reply 4 of 17
    1; Are you sure you are the administrator? Usually, your symptoms indicate that you don't have enough privileges to modify some system preferences.



    I am the Admin since this is my personal Flower Imac.

    first time I installed 10.2.8 it was on same volume as my 9.2.2 that I had used for one and a half years, so I thought maybe that if I reinstalled both systems it would solve it, which I did to no avail. Third time I erased the HD and installed 10.2.8 on one partion and 9.2.2 on the second one, both are pristine systems right now and the problem is there.



    2; If it's not something that simple, then I'd try repairing permissions, and then, lastly, looking for the system prefs cache in your Library/Caches folder.



    I have repaired permissions over and over again(using disk utility from install cd, utility from the HD). I must stress that the problem is gone when I unplug the ethernet cable that is connected to my dsl modem, but immediately returns when I plug it back in, But I will hunt for a padlock.

    When I look for the system prefs cache in library/chaches, do I trash it after I find it?.



    3; Is your Mac part of a campus network (or was it at one time)?



    I am on no network at all and never have been, I'm at home.



    Thank you for the suggestions and I will be implementing a couple. Please keep thinking of this as I know that your heads are much better than mine at os x!!!



    Apple assured me it was not my imac hardware, and SBC assured me it isn't my dsl modem!!! grrrrr!



    Vicki
  • Reply 5 of 17
    davegeedavegee Posts: 2,765member
    Still seems to me like your machine is or was on a shared network with a one of the other Macs running OS X Server. No other Macs in the house? If so could that machine be running OS X Server?



    Do this for me ...



    Go to your Applications Folder and then into the Utilities Folder and run the program called Netinfo Manager. (don't click on the lock - you DON'T want to change anything)... You should see a 3 column view with / in the first column and a list of things in the second column... In that list of things do you have something called mcx_cache? Next, click on config? or configurations (if its in that list) and tell me if you see another mcx_cache listed.



    Then you can simply quite the program.



    If you have either (or both) mcx_cache items then you have (at some time) been in contact with an OS X Server running somewhere.



    Sorry but the 'dimmed' items in System Preference is EXACTLY what happens in a 'Managed' environment (where an OS X Server has the ability to lock up specific settings). A school or work environment is where this happens most often.



    Dave
  • Reply 6 of 17
    DaveGee,



    Thank you for your help here. I did what you told me to and there are no mcx_cache files under / or under config in my netinfo manager utility. I would send you a sceenshot of my netinfo manager window but at the bottom of my posting screen it tells me that I cannot add an attachment



    I am a little confused about this os x server thing as, I don't know what osx server is......I guess I have to do some research on that as well.

    My os x runs beautifully!!! I love it!!! , but it is really frustrating to have to unplug my ethernet connection every time I want to change some of my settings!.



    I was really hopeful that you had narrowed my problem down, but looks like not yet. I am reading everything that I possibly can to see what the problem could be here, I am one of those people who are totally driven to correct something when it isn't right in every way.



    I could email them to you, but I do not know if that is allowed or not on this board.





    Vicki
  • Reply 7 of 17
    davegeedavegee Posts: 2,765member
    Quote:

    Originally posted by vickid

    DaveGee,



    Thank you for your help here. I did what you told me to and there are no mcx_cache files under / or under config in my netinfo manager utility. I would send you a sceenshot of my netinfo manager window but at the bottom of my posting screen it tells me that I cannot add an attachment




    Well that totally nuked my idea... you SHOULD NOT have mcx_cache entries... Those are used by OS X Server to send forced settings and also used to restrict what applications and system preferences the user is allowed to see. This only reason I was obsessing about that is I'm currently working quite a bit with managed settings where I work and your experience closely matched what an OS X server could do to a machine.



    In short it's 'good' that you don't have them.



    Okay try one more thing...



    Create a brand new fresh account (call it test if you like) and give it Admin privileges.



    Once done shut down the machine (leave it connected to the network/internet). Power on the machine and (If auto-login is turned on you may have to 'logout' of your old account first) and then login as that test account.



    Does the problem still exist?



    This will narrow down if the problem is isolated to just your specific login account or if it's a more system wide problem.



    Dave



    P.S. After re-reading what you said above... did you say you did a format install and the problem STILL existed?!?!



    As in..



    Had the problem

    Format installed a fresh OS X (no copying of anything else back to the system)

    Still had the problem



    If that's the case this is really weird... Not that I think it'll make a difference but did you zap the pram?



    Before/While powering up the machine hold down the following 4 keys at the same time.



    command (the 'apple key')

    option

    p

    r



    Not easy but you can do it!



    Gotta hold them both down while the machine is turning on shortly after the first 'boot chime' you'll hear another chime (keep holding it down till you hear it chime a few times) 3 chimes should be fine.



    Then release the keys and let the machine finish booting...
  • Reply 8 of 17
    adamraoadamrao Posts: 175member
    Could it be that when you're on the network/internet (SBC DSL) that their servers are restricting some of his privledges? Have you tried hooking up to someone else's network/internet (someone without SBC DSL) to see if the problem still exists?



    If it doesn't happen when you're NOT on SBC DSL, then it must be something with SBC's network... maybe a server is restricting you. I didn't think that was possible... but who knows.



    If it continues to happen regardless of what kind of network you plug into... then I would guess that there is something wrong with your ethernet card. Something is causing Mac OS X to recognize some sort of restrictions when you are "plugged in."



    I would be interested to see if it happened with Airport/wireless access as well. Let's keep working on this... we'll get it at some point.
  • Reply 9 of 17
    adamraoadamrao Posts: 175member
    I just thought of something else...



    Does SBC give you an "emergency" dial-up # that you can use in case your DSL goes down? If so, try connecting to the internet with that and see if the same problem occurs.



    Also... what settings are greyed out in your system preferences when you do plug in? Specifics please.
  • Reply 10 of 17
    Dave,



    I reformated after installing the second time.....I erased my drive, patitioned it in two partitions, and installed a clean os x on one and a clean os 9.1 on the other, I installed nothing third party and the problem was there when ethernet was plugged in.



    the control panels that are affected are only these.....Accounts(won't let me add a new one.etc.), Energy Saver(won't let me change any settings), Network(usually it will not even launch, if it does launch I have to force quit it and it is all greyed out), Sharing(all options are greyed out), Startup Disk(box is blank, neither of my volumes show up). Of course when the ethernet is plugged in all of them work.



    I have made my son and the children in the famil accounts, my son's account is an admin, and the kids account is not. When ethernet is plugged in the above mentioned control panels can't be changed in my son's admin account or in the kids account, but when unplugged they do work in my son't admin account.



    SBC does not supply an emergency dial-up, but I use aol as a backup and when aol is running on dial-up it does not affect my system panels. I talked to SBC and they say that everything is fine with my ethernet, they checked my numbers and said I have an excellent connection. Apple says it isn't my hardware, but I can't afford another call to Apple as my Apple care has expired, and they didn't think my ethernet card was the problem either.



    I am did zap the pram as Apple told me to do that when I talked with them.



    Adamrao,

    I called SBC tonight after ready your suggestions and they tell me there is no way they could restrict me in that way.

    I have no one that I know that has dsl or an ethernet connection to internet



    This is just stupify!!!, I have done everything that I know of



    when I am connected to ethernet I can't access Netinfo utility either.
  • Reply 11 of 17
    kwondokwondo Posts: 217member
    I'm not sure how it will result globally on your mac but have you tried these following?



    1. son'd home folder, "get info", make sure that "Locked" is NOT check marked. Under Ownership and Permissions change permissions to read and write in all levels (just for the hell of it) and then select "Apply to enclosed items."



    If that doesn't work, go to 2.



    2. do same as above except select the OS X HD, then hopefully, it will work. If it does, then do your changes of the "Network" and then afterwards, run disk repair and do a "Repair permissions."



    Good luck!
  • Reply 12 of 17
    kwondo,



    I did what you said and was unable to change "Son's" permissions I could unlock it but couldn't change it. I could not change HD either, couldn't change them either with the ethernet plugged in or without it plugged in. I ran disk utility also ....all to no avail. I was able to change mine however.



    Everyone,

    This has me so upset!!, am I am grateful to all of you for your brainstorming as I am the only mac user I know and I do not know what to do.
  • Reply 13 of 17
    davegeedavegee Posts: 2,765member
    Are you launching classic (os 9) at startup? Not that I think it's making a difference but at this point we're all grasping right? If you are stop it and check...



    This is really too much... I've never heard of such a thing before.



    Okay one final thing... (since I don't think stopping classic will work) why not do the following.



    1 - unplug ethernet

    2 - launch "Directory Access" found in Applications/Utilities

    3 - turn off ldap and netinfo press apply and quit

    4 - shutdown

    5 - plugin ethernet

    6 - restart



    Since your not in a network environment you don't need either of those on anyway...



    Dave
  • Reply 14 of 17
    Dave,



    Thank you for trying so hard to help me here.

    I don't launch os 9 at all, am trying to not use it simply because I need to ween myself away from it.



    I did what you replied, step by step and no change. I am still facing the same bewildering problem, the system prefs that I can't change when ethernet is plugged in ..still unable to change them....I unplug ethernet cable and wallah.....I am able to change them....I am so frustrated at this point !!. I have been a mac user since 1997 and pretty much knew my os inside and out, but not now!!.





    Vicki



    Thank you to all for trying to get this sorted out.
  • Reply 15 of 17
    kwondokwondo Posts: 217member
    vikid,



    Do what I suggested without the eathernet plugged in. Change permissions and ownership. once that is done, you should try plugging the ethernet cable back in. The fact that you cannot change the permissions and ownership shows that you are at limited control login. Someone has higher power. Also check under sys pref "Accounts" and see is you or your son's accounts are "admins" account and or whether managed or padlocked.
  • Reply 16 of 17
    Is there any way that you can log in as root to see if the System Prefs are still greyed out? That should be the only thing "above" Admin on the system. Maybe something needs to be changed at the root level?



    Wish you had someone you knew with ethernet internet access... Though I doubt it's SBC's network. It really shouldn't be. Maybe even a library or a university/college nearby?



    Any chance you could get a hold of Panther and try an install of that? It sounds like you've formatted your disk so many times already, why would it hurt to do it again? I wonder if the problem exists in Panther too or only in Jaguar. Have you tried different versions of Jaguar? 10.2.7 instead of 10.2.8 to see if it's a problem with the update?
  • Reply 17 of 17
    Adamrao,



    I created a root account under my name, when I "got info" for "network" it says:



    Owner- ____(me)

    access- Read & write

    Group- Admin

    access- read only

    Others- read only



    I am able to change owner and group, but I can't change any access....so this is confusing....are these settings right??



    If i click my HD I can change all items



    When I install os x from my install cd, it installs as 10.2.3 then I upgrade to 10.2.8 via "softwear update", but the problem is there immediately upon clean install and does not go away with the upgrade.



    as far as testing the ethernet network for sbc, when I connect my Panasonic laptop running XP Home, everything is fine, so I have kinda ruled out SBC.



    I really feel so very dumb here. this has me totally stumped and my knowledge os os x is pretty limited yet until I understand it a little better, the ownership and permissions thing is pretty bewildering for me yet.
Sign In or Register to comment.