2 System Preferences Not Working

Posted:
in Genius Bar edited January 2014
This is really baffling me. I am running 10.3.7 with all the security updates on a PowerMac G4 MDD.



For quite a while, the Speech preference pane simply will not load. It crashes every time. I could live with this because I never use it.



But now, the Accounts preference pane has gone bad as well. I am able to delete users, but not add them. Mouse-clicking on the "+" button produces no result. This bothers me as I usually have at least one test user for troubleshooting software. I deleted the only one I had to see if the prefpane worked on the minus button. That worked OK. Now, I cannot re-create the test user. The same result (nothing) happens with every user including root. It also happens on a safeboot as well.



Edited: I am especially leery of fooling with the .plist file for Accounts or for extracting and substituting from older 10.3 versions as I have a feeling that this may mess up the existing users beyond repair.



As I say, the speech prefpane I don't need. The account prefpane, I do.



I have already checked in Netinfo to make sure there were no users with either a name or realname with a NULL value, so that's not the problem.



Any ideas greatly appreciated.

Comments

  • Reply 1 of 2
    Hey. Have had asimilar problem a while back. This is how i solved it. Hope it helps.



    Delete ~/Library/Caches/com.apple.preferencepanes.cache



    Hope that works



    If not get back to me



    Streamer
  • Reply 2 of 2
    mcsjgsmcsjgs Posts: 244member
    Thanks, Streamer, but this is an old post, and I did do what you suggested. I solved it by a clean reinstall. Thanks tho



    Edited: I had to do a clean reinstall because I foolishly screwed up the Netinfo database. Plus I wanted to see what a clean reinstall was like in preparation for Tiger. End compulsive need to share mode.
Sign In or Register to comment.