Pismo fails to start up after upgrades.

in Genius Bar edited January 2014
My friend's G3 500mHz Pismo powerbook won't start up. Just replaced the hard drive, upgrading from the original 20GB to a 60 GB Hitachi 7200rpm from Transintl.com; and, at the same time replaced the lower RAM chip with a 512 MB chip from Crucial (both upgrades specifically recommended for the Pismo).

Powerbook was working ok before the upgrades, which went very smoothly, no problems, but now, it won't start up. Nothing happens when we press the power button. But the cap locks light will turn on. Checked all the power cord connections, completely redid the installations, double checking that the daughter card was properly seated. Reset the PMU several times using the button on the back w/all power disconnected. This would turn off the caps lock light, but still no joy upon reconnecting power & attempting to start up.

We intended to boot from a external firewire backup drive, then initialize the new internal drive, and clone the OS (Panther) back to it. We would very much appreciate any ideas about what to do next.


  • Reply 1 of 2
    First, I would put the old harddrive back in, leave the new ram in, and see if it boots fine. If it does then you know the problem is with the new harddrive. If not then the problem is with the new ram.

    Thats just what I would in a situation like that.... gotta find out where the problem is first.
  • Reply 2 of 2
    ebbyebby Posts: 3,110member
    HAHAHA! Deja vu! Scared the crap out of me too when it happened to me.

    Wonder down to michael's post. That is what solved it for me.
Sign In or Register to comment.